{"answers":{"affected":"3 open source packages ship an affected version, including fluentd. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-44160 in the wild and no public exploit code.","fix":"Upgrade fluentd to 1.19.3 or later.","what":"CVE-2026-44160 is a high-severity denial of service vulnerability in fluentd, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44160 and fix it if it is affected.\n\nWhat it is: CVE-2026-44160 is a high-severity denial of service vulnerability in fluentd, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44160 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fluentd (Bitnami): affected all versions; fixed in 1.19.3\n- fluentd (RubyGems): affected all versions; fixed in 1.19.3\n- fluentd (RubyGems): affected all versions; fixed in 1.19.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44160/ (Markdown: https://insights.sbomify.com/CVE-2026-44160/index.md)","id":"CVE-2026-44160","markdown":"https://insights.sbomify.com/CVE-2026-44160/index.md","name":"CVE-2026-44160","record":{"aliases":["BIT-fluentd-2026-44160","CLEANSTART-2026-PM11258","CLEANSTART-2026-UM68205","GHSA-j9cw-hwqf-85w7","MINI-4jw4-crxh-wffh","MINI-4mpc-h42q-mxrq","MINI-7m6x-cjx6-4xqv","MINI-8m67-ccr6-483c","MINI-cj8q-8c95-8xwc","MINI-ffr7-9g79-34gw","MINI-g8vm-f42g-4gc7","MINI-gmfh-8cv2-jwcp","MINI-hcg7-4m6g-hj99","MINI-j78w-vrr3-gj2p","MINI-m5v5-wchh-6m6w","MINI-p6c8-hcx5-qxfr","MINI-v3p8-phwj-7vfg","MINI-vm5p-87rm-973r","MINI-xgmc-v89c-c9f9"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Fluentd log collector","requires_auth":"none","summary":"Attackers can cause denial of service in Fluentd by sending gzip-compressed payloads that exhaust memory during decompression.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fluentd","vendor":"fluentd"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"}],"description":"Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd's in_http and in_forward plugins support gzip-compressed data but enforce limits only on compressed payloads through settings such as body_size_limit and chunk_size_limit, allowing crafted compressed payloads to decompress in memory to an excessive size and cause denial of service through memory exhaustion. This issue is fixed in version 1.19.3.","ecosystems":["Bitnami","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward`","id":"CVE-2026-44160","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`","id":"CVE-2026-44161"},"packages":[{"ecosystem":"Bitnami","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"fluentd","purl":"pkg:bitnami/fluentd","source":"BIT-fluentd-2026-44160"},{"ecosystem":"RubyGems","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"fluentd","purl":null,"source":"GHSA-j9cw-hwqf-85w7"},{"ecosystem":"RubyGems","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"fluentd","purl":"pkg:gem/fluentd","source":"GHSA-j9cw-hwqf-85w7"}],"prev":{"headline":"Tyler Identity Local (TID-L) default administrative credentials","id":"CVE-2026-44159"},"products":["fluentd"],"published":"2026-07-08","related":[{"cvss_score":9.8,"headline":"Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder","id":"CVE-2026-44024","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":9.8,"headline":"Fluentd Escape Sequence Injection Vulnerability","id":"CVE-2017-10906","kev_date_added":null,"published":"2017-12-08"},{"cvss_score":8.8,"headline":"Fluent Fluentd and Fluent-ui use default password","id":"CVE-2020-21514","kev_date_added":null,"published":"2023-04-04"},{"cvss_score":7.5,"headline":"Fluentd: Exposure of Sensitive Information via Monitor Agent API","id":"CVE-2026-44025","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":7.2,"headline":"Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`","id":"CVE-2026-44161","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":5.9,"headline":"ReDoS vulnerability in parser_apache2","id":"CVE-2021-41186","kev_date_added":null,"published":"2021-10-29"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["fluent"]},"summary":"Attackers can cause denial of service in Fluentd by sending gzip-compressed payloads that exhaust memory during decompression.","url":"https://insights.sbomify.com/CVE-2026-44160/"}