# CVE-2026-44160: Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward`

> Attackers can cause denial of service in Fluentd by sending gzip-compressed payloads that exhaust memory during decompression.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-fluentd-2026-44160, CLEANSTART-2026-PM11258, CLEANSTART-2026-UM68205, GHSA-j9cw-hwqf-85w7, MINI-4jw4-crxh-wffh, MINI-4mpc-h42q-mxrq, MINI-7m6x-cjx6-4xqv, MINI-8m67-ccr6-483c, MINI-cj8q-8c95-8xwc, MINI-ffr7-9g79-34gw, MINI-g8vm-f42g-4gc7, MINI-gmfh-8cv2-jwcp, MINI-hcg7-4m6g-hj99, MINI-j78w-vrr3-gj2p, MINI-m5v5-wchh-6m6w, MINI-p6c8-hcx5-qxfr, MINI-v3p8-phwj-7vfg, MINI-vm5p-87rm-973r, MINI-xgmc-v89c-c9f9

## What is CVE-2026-44160?

CVE-2026-44160 is a high-severity denial of service vulnerability in fluentd, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd's in_http and in_forward plugins support gzip-compressed data but enforce limits only on compressed payloads through settings such as body_size_limit and chunk_size_limit, allowing crafted compressed payloads to decompress in memory to an excessive size and cause denial of service through memory exhaustion. This issue is fixed in version 1.19.3.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-44160?

3 open source packages ship an affected version, including fluentd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluentd` | Bitnami | All versions | 1.19.3 |
| `fluentd` | RubyGems | All versions | 1.19.3 |
| `fluentd` | RubyGems | All versions | 1.19.3 |

Products: Fluentd Fluentd.

## How do I fix CVE-2026-44160?

Upgrade fluentd to 1.19.3 or later.

## Is CVE-2026-44160 being exploited?

There is no known exploitation of CVE-2026-44160 in the wild and no public exploit code.

## Other vulnerabilities in fluentd

- [CVE-2026-44024](https://insights.sbomify.com/CVE-2026-44024/): Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder (critical 9.8)
- [CVE-2017-10906](https://insights.sbomify.com/CVE-2017-10906/): Fluentd Escape Sequence Injection Vulnerability (critical 9.8)
- [CVE-2020-21514](https://insights.sbomify.com/CVE-2020-21514/): Fluent Fluentd and Fluent-ui use default password (high 8.8)
- [CVE-2026-44025](https://insights.sbomify.com/CVE-2026-44025/): Fluentd: Exposure of Sensitive Information via Monitor Agent API (high 7.5)
- [CVE-2026-44161](https://insights.sbomify.com/CVE-2026-44161/): Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http` (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44160 and fix it if it is affected.

What it is: CVE-2026-44160 is a high-severity denial of service vulnerability in fluentd, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44160 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluentd (Bitnami): affected all versions; fixed in 1.19.3
- fluentd (RubyGems): affected all versions; fixed in 1.19.3
- fluentd (RubyGems): affected all versions; fixed in 1.19.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44160/ (Markdown: https://insights.sbomify.com/CVE-2026-44160/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44160
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44160
- OSV: https://osv.dev/vulnerability/CVE-2026-44160

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44160/
Summaries are generated and may contain mistakes; the official description above is the record.
