{"answers":{"affected":"3 open source packages ship an affected version, including fluentd. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-44161 in the wild and no public exploit code.","fix":"Upgrade fluentd to 1.19.3 or later.","what":"CVE-2026-44161 is a high-severity server-side request forgery vulnerability in fluentd, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44161 and fix it if it is affected.\n\nWhat it is: CVE-2026-44161 is a high-severity server-side request forgery vulnerability in fluentd, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44161 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fluentd (Bitnami): affected all versions; fixed in 1.19.3\n- fluentd (RubyGems): affected all versions; fixed in 1.19.3\n- fluentd (RubyGems): affected all versions; fixed in 1.19.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44161/ (Markdown: https://insights.sbomify.com/CVE-2026-44161/index.md)","id":"CVE-2026-44161","markdown":"https://insights.sbomify.com/CVE-2026-44161/index.md","name":"CVE-2026-44161","record":{"aliases":["BIT-fluentd-2026-44161","CLEANSTART-2026-NY70538","CLEANSTART-2026-RY78730","GHSA-72f5-rr8c-r6gr","MINI-5h49-72r6-4m6x","MINI-6r37-5x78-v6m4","MINI-8jwp-2r55-vwfc","MINI-93rg-q4wx-v3ww","MINI-94p3-qj8p-j26w","MINI-985r-7759-vx63","MINI-9p9p-9jj3-jmrr","MINI-ch9p-9h6c-xx2c","MINI-cph3-2hxc-2h6h","MINI-gxm7-2pwc-jmj2","MINI-pm4g-hm9m-vfq7","MINI-r965-jp2m-fjvq","MINI-vm25-v4mq-58qw","MINI-x33q-8frj-x2ff","MINI-xjc9-99cv-p6c8"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Fluentd log collector","requires_auth":"none","summary":"Attackers can exploit placeholder expansion in the out_http plugin to force Fluentd to send requests to arbitrary internal services, enabling SSRF attacks.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fluentd","vendor":"fluentd"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, the Fluentd out_http output plugin allows placeholders such as ${tag} in the endpoint configuration parameter, and if a placeholder value is derived from untrusted input an attacker can control the destination hostname of outbound HTTP requests and force requests to arbitrary internal services. This issue is fixed in version 1.19.3.","ecosystems":["Bitnami","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`","id":"CVE-2026-44161","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"fluent-plugin-s3: Denial of Service (DoS) via Decompression Bomb in `in_s3`","id":"CVE-2026-44162"},"packages":[{"ecosystem":"Bitnami","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"fluentd","purl":"pkg:bitnami/fluentd","source":"BIT-fluentd-2026-44161"},{"ecosystem":"RubyGems","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"fluentd","purl":null,"source":"GHSA-72f5-rr8c-r6gr"},{"ecosystem":"RubyGems","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"fluentd","purl":"pkg:gem/fluentd","source":"GHSA-72f5-rr8c-r6gr"}],"prev":{"headline":"Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward`","id":"CVE-2026-44160"},"products":["fluentd"],"published":"2026-07-08","related":[{"cvss_score":9.8,"headline":"Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder","id":"CVE-2026-44024","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":9.8,"headline":"Fluentd Escape Sequence Injection Vulnerability","id":"CVE-2017-10906","kev_date_added":null,"published":"2017-12-08"},{"cvss_score":8.8,"headline":"Fluent Fluentd and Fluent-ui use default password","id":"CVE-2020-21514","kev_date_added":null,"published":"2023-04-04"},{"cvss_score":7.5,"headline":"Fluentd: Exposure of Sensitive Information via Monitor Agent API","id":"CVE-2026-44025","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":7.5,"headline":"Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward`","id":"CVE-2026-44160","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":5.9,"headline":"ReDoS vulnerability in parser_apache2","id":"CVE-2021-41186","kev_date_added":null,"published":"2021-10-29"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["fluent"]},"summary":"Attackers can exploit placeholder expansion in the out_http plugin to force Fluentd to send requests to arbitrary internal services, enabling SSRF attacks.","url":"https://insights.sbomify.com/CVE-2026-44161/"}