# CVE-2026-44161: Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`

> Attackers can exploit placeholder expansion in the out_http plugin to force Fluentd to send requests to arbitrary internal services, enabling SSRF attacks.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-fluentd-2026-44161, CLEANSTART-2026-NY70538, CLEANSTART-2026-RY78730, GHSA-72f5-rr8c-r6gr, MINI-5h49-72r6-4m6x, MINI-6r37-5x78-v6m4, MINI-8jwp-2r55-vwfc, MINI-93rg-q4wx-v3ww, MINI-94p3-qj8p-j26w, MINI-985r-7759-vx63, MINI-9p9p-9jj3-jmrr, MINI-ch9p-9h6c-xx2c, MINI-cph3-2hxc-2h6h, MINI-gxm7-2pwc-jmj2, MINI-pm4g-hm9m-vfq7, MINI-r965-jp2m-fjvq, MINI-vm25-v4mq-58qw, MINI-x33q-8frj-x2ff, MINI-xjc9-99cv-p6c8

## What is CVE-2026-44161?

CVE-2026-44161 is a high-severity server-side request forgery vulnerability in fluentd, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, the Fluentd out_http output plugin allows placeholders such as ${tag} in the endpoint configuration parameter, and if a placeholder value is derived from untrusted input an attacker can control the destination hostname of outbound HTTP requests and force requests to arbitrary internal services. This issue is fixed in version 1.19.3.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-44161?

3 open source packages ship an affected version, including fluentd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluentd` | Bitnami | All versions | 1.19.3 |
| `fluentd` | RubyGems | All versions | 1.19.3 |
| `fluentd` | RubyGems | All versions | 1.19.3 |

Products: Fluentd Fluentd.

## How do I fix CVE-2026-44161?

Upgrade fluentd to 1.19.3 or later.

## Is CVE-2026-44161 being exploited?

There is no known exploitation of CVE-2026-44161 in the wild and no public exploit code.

## Other vulnerabilities in fluentd

- [CVE-2026-44024](https://insights.sbomify.com/CVE-2026-44024/): Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder (critical 9.8)
- [CVE-2017-10906](https://insights.sbomify.com/CVE-2017-10906/): Fluentd Escape Sequence Injection Vulnerability (critical 9.8)
- [CVE-2020-21514](https://insights.sbomify.com/CVE-2020-21514/): Fluent Fluentd and Fluent-ui use default password (high 8.8)
- [CVE-2026-44025](https://insights.sbomify.com/CVE-2026-44025/): Fluentd: Exposure of Sensitive Information via Monitor Agent API (high 7.5)
- [CVE-2026-44160](https://insights.sbomify.com/CVE-2026-44160/): Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward` (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44161 and fix it if it is affected.

What it is: CVE-2026-44161 is a high-severity server-side request forgery vulnerability in fluentd, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44161 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluentd (Bitnami): affected all versions; fixed in 1.19.3
- fluentd (RubyGems): affected all versions; fixed in 1.19.3
- fluentd (RubyGems): affected all versions; fixed in 1.19.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44161/ (Markdown: https://insights.sbomify.com/CVE-2026-44161/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44161
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44161
- OSV: https://osv.dev/vulnerability/CVE-2026-44161

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44161/
Summaries are generated and may contain mistakes; the official description above is the record.
