CVE-2026-44162 fluent-plugin-s3: Denial of Service (DoS) via Decompression Bomb in `in_s3`
An attacker uploading compressed files to S3 can cause memory exhaustion and crash Fluentd, disrupting log collection.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44162?
CVE-2026-44162 is a low-severity denial of service vulnerability in fluent-plugin-s3, published on 14 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
fluent-plugin-s3 is an Amazon S3 input and output plugin for Fluentd. From 0.7.0 to 1.8.4, the in_s3 input plugin reads the entire decompressed payload of gzip, lzma2, and lzop objects into memory without enforcing a decompression_size_limit. An attacker with permission to upload objects to the monitored S3 bucket can provide a highly compressed object that expands excessively when Fluentd processes it. The resulting memory exhaustion can cause the operating system to terminate the Fluentd process and disrupt all log collection on the affected node. This issue is fixed in version 1.8.5.
Weakness: CWE-409
Which versions are affected by CVE-2026-44162?
2 open source packages ship an affected version, including fluent-plugin-s3.
| Package | Affected | Fixed in |
|---|---|---|
fluent-plugin-s3 RubyGems | From 0.7.0 | 1.8.5 |
fluent-plugin-s3 RubyGems | From 0.7.0 | 1.8.5 |
How do I fix CVE-2026-44162?
Upgrade fluent-plugin-s3 to 1.8.5 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-44162 being exploited?
There is no known exploitation of CVE-2026-44162 in the wild and no public exploit code.
Sources
Also known as GHSA-xv9w-7v6q-hpjh, MINI-2hqw-38p3-4qxr, MINI-9hff-7wr4-6wf8, MINI-r8xc-c2jc-xf6h.