{"answers":{"affected":"2 open source packages ship an affected version, including fluent-plugin-s3.","exploited":"There is no known exploitation of CVE-2026-44162 in the wild and no public exploit code.","fix":"Upgrade fluent-plugin-s3 to 1.8.5 or later.","what":"CVE-2026-44162 is a low-severity denial of service vulnerability in fluent-plugin-s3, published on 14 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44162 and fix it if it is affected.\n\nWhat it is: CVE-2026-44162 is a low-severity denial of service vulnerability in fluent-plugin-s3, published on 14 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44162 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fluent-plugin-s3 (RubyGems): affected from 0.7.0; fixed in 1.8.5\n- fluent-plugin-s3 (RubyGems): affected from 0.7.0; fixed in 1.8.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44162/ (Markdown: https://insights.sbomify.com/CVE-2026-44162/index.md)","id":"CVE-2026-44162","markdown":"https://insights.sbomify.com/CVE-2026-44162/index.md","name":"CVE-2026-44162","record":{"aliases":["GHSA-xv9w-7v6q-hpjh","MINI-2hqw-38p3-4qxr","MINI-9hff-7wr4-6wf8","MINI-r8xc-c2jc-xf6h"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Fluentd S3 plugin","requires_auth":"high_privilege","summary":"An attacker uploading compressed files to S3 can cause memory exhaustion and crash Fluentd, disrupting log collection.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"}],"description":"fluent-plugin-s3 is an Amazon S3 input and output plugin for Fluentd. From 0.7.0 to 1.8.4, the in_s3 input plugin reads the entire decompressed payload of gzip, lzma2, and lzop objects into memory without enforcing a decompression_size_limit. An attacker with permission to upload objects to the monitored S3 bucket can provide a highly compressed object that expands excessively when Fluentd processes it. The resulting memory exhaustion can cause the operating system to terminate the Fluentd process and disrupt all log collection on the affected node. This issue is fixed in version 1.8.5.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"fluent-plugin-s3: Denial of Service (DoS) via Decompression Bomb in `in_s3`","id":"CVE-2026-44162","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"fluent-plugin-opentelemetry: Denial of Service (DoS) via Large Payloads and Decompression Bombs in `in_opentelemetry`","id":"CVE-2026-44163"},"packages":[{"ecosystem":"RubyGems","fixed":["1.8.5"],"introduced":["0.7.0"],"last_affected":[],"package":"fluent-plugin-s3","purl":null,"source":"GHSA-xv9w-7v6q-hpjh"},{"ecosystem":"RubyGems","fixed":["1.8.5"],"introduced":["0.7.0"],"last_affected":[],"package":"fluent-plugin-s3","purl":"pkg:gem/fluent-plugin-s3","source":"GHSA-xv9w-7v6q-hpjh"}],"prev":{"headline":"Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`","id":"CVE-2026-44161"},"products":["fluent-plugin-s3"],"published":"2026-09-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-14","vendors":["fluent"]},"summary":"An attacker uploading compressed files to S3 can cause memory exhaustion and crash Fluentd, disrupting log collection.","url":"https://insights.sbomify.com/CVE-2026-44162/"}