# CVE-2026-44162: fluent-plugin-s3: Denial of Service (DoS) via Decompression Bomb in `in_s3`

> An attacker uploading compressed files to S3 can cause memory exhaustion and crash Fluentd, disrupting log collection.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-xv9w-7v6q-hpjh, MINI-2hqw-38p3-4qxr, MINI-9hff-7wr4-6wf8, MINI-r8xc-c2jc-xf6h

## What is CVE-2026-44162?

CVE-2026-44162 is a low-severity denial of service vulnerability in fluent-plugin-s3, published on 14 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

fluent-plugin-s3 is an Amazon S3 input and output plugin for Fluentd. From 0.7.0 to 1.8.4, the in_s3 input plugin reads the entire decompressed payload of gzip, lzma2, and lzop objects into memory without enforcing a decompression_size_limit. An attacker with permission to upload objects to the monitored S3 bucket can provide a highly compressed object that expands excessively when Fluentd processes it. The resulting memory exhaustion can cause the operating system to terminate the Fluentd process and disrupt all log collection on the affected node. This issue is fixed in version 1.8.5.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-44162?

2 open source packages ship an affected version, including fluent-plugin-s3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluent-plugin-s3` | RubyGems | From 0.7.0 | 1.8.5 |
| `fluent-plugin-s3` | RubyGems | From 0.7.0 | 1.8.5 |

## How do I fix CVE-2026-44162?

Upgrade fluent-plugin-s3 to 1.8.5 or later.

## Is CVE-2026-44162 being exploited?

There is no known exploitation of CVE-2026-44162 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44162 and fix it if it is affected.

What it is: CVE-2026-44162 is a low-severity denial of service vulnerability in fluent-plugin-s3, published on 14 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44162 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluent-plugin-s3 (RubyGems): affected from 0.7.0; fixed in 1.8.5
- fluent-plugin-s3 (RubyGems): affected from 0.7.0; fixed in 1.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44162/ (Markdown: https://insights.sbomify.com/CVE-2026-44162/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44162
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44162
- OSV: https://osv.dev/vulnerability/CVE-2026-44162

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44162/
Summaries are generated and may contain mistakes; the official description above is the record.
