{"answers":{"affected":"2 open source packages ship an affected version, including fluent-plugin-opentelemetry.","exploited":"There is no known exploitation of CVE-2026-44163 in the wild and no public exploit code.","fix":"Upgrade fluent-plugin-opentelemetry to 0.5.3 or later.","what":"CVE-2026-44163 is a medium-severity denial of service vulnerability in fluent-plugins-nursery fluent-plugin-opentelemetry, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44163 and fix it if it is affected.\n\nWhat it is: CVE-2026-44163 is a medium-severity denial of service vulnerability in fluent-plugins-nursery fluent-plugin-opentelemetry, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44163 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fluent-plugin-opentelemetry (RubyGems): affected all versions; fixed in 0.5.3\n- fluent-plugin-opentelemetry (RubyGems): affected all versions; fixed in 0.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44163/ (Markdown: https://insights.sbomify.com/CVE-2026-44163/index.md)","id":"CVE-2026-44163","markdown":"https://insights.sbomify.com/CVE-2026-44163/index.md","name":"CVE-2026-44163","record":{"aliases":["GHSA-2jc5-xhx8-qj6h"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Fluentd OpenTelemetry plugin","requires_auth":"none","summary":"Attackers can crash Fluentd by sending large or compressed payloads to the OpenTelemetry input plugin, disrupting log collection.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"}],"description":"fluent-plugin-opentelemetry is a Fluentd input and output plugin for forwarding OpenTelemetry Protocol data. Prior to 0.5.3, the in_opentelemetry HTTP input read the entire incoming request body and decompressed payloads into memory without enforcing maximum size thresholds. When an OpenTelemetry ingestion endpoint was exposed to an untrusted network, an attacker could send an excessively large request or a highly compressed payload that expanded in memory. The resulting memory exhaustion could cause the operating system to terminate the Fluentd process, disrupting all log collection and forwarding on the affected node. This issue is fixed in version 0.5.3.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"fluent-plugin-opentelemetry: Denial of Service (DoS) via Large Payloads and Decompression Bombs in `in_opentelemetry`","id":"CVE-2026-44163","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Pocketbase: Account pre-hijacking via OAuth2 unverfied-\u003everified autolinking upgrade","id":"CVE-2026-44166"},"packages":[{"ecosystem":"RubyGems","fixed":["0.5.3"],"introduced":["0"],"last_affected":[],"package":"fluent-plugin-opentelemetry","purl":null,"source":"GHSA-2jc5-xhx8-qj6h"},{"ecosystem":"RubyGems","fixed":["0.5.3"],"introduced":["0"],"last_affected":[],"package":"fluent-plugin-opentelemetry","purl":"pkg:gem/fluent-plugin-opentelemetry","source":"GHSA-2jc5-xhx8-qj6h"}],"prev":{"headline":"fluent-plugin-s3: Denial of Service (DoS) via Decompression Bomb in `in_s3`","id":"CVE-2026-44162"},"products":["fluent-plugin-opentelemetry"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-16","vendors":["fluent-plugins-nursery"]},"summary":"Attackers can crash Fluentd by sending large or compressed payloads to the OpenTelemetry input plugin, disrupting log collection.","url":"https://insights.sbomify.com/CVE-2026-44163/"}