# CVE-2026-44163: fluent-plugin-opentelemetry: Denial of Service (DoS) via Large Payloads and Decompression Bombs in `in_opentelemetry`

> Attackers can crash Fluentd by sending large or compressed payloads to the OpenTelemetry input plugin, disrupting log collection.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-2jc5-xhx8-qj6h

## What is CVE-2026-44163?

CVE-2026-44163 is a medium-severity denial of service vulnerability in fluent-plugins-nursery fluent-plugin-opentelemetry, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fluent-plugin-opentelemetry is a Fluentd input and output plugin for forwarding OpenTelemetry Protocol data. Prior to 0.5.3, the in_opentelemetry HTTP input read the entire incoming request body and decompressed payloads into memory without enforcing maximum size thresholds. When an OpenTelemetry ingestion endpoint was exposed to an untrusted network, an attacker could send an excessively large request or a highly compressed payload that expanded in memory. The resulting memory exhaustion could cause the operating system to terminate the Fluentd process, disrupting all log collection and forwarding on the affected node. This issue is fixed in version 0.5.3.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-44163?

2 open source packages ship an affected version, including fluent-plugin-opentelemetry.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluent-plugin-opentelemetry` | RubyGems | All versions | 0.5.3 |
| `fluent-plugin-opentelemetry` | RubyGems | All versions | 0.5.3 |

## How do I fix CVE-2026-44163?

Upgrade fluent-plugin-opentelemetry to 0.5.3 or later.

## Is CVE-2026-44163 being exploited?

There is no known exploitation of CVE-2026-44163 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44163 and fix it if it is affected.

What it is: CVE-2026-44163 is a medium-severity denial of service vulnerability in fluent-plugins-nursery fluent-plugin-opentelemetry, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44163 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluent-plugin-opentelemetry (RubyGems): affected all versions; fixed in 0.5.3
- fluent-plugin-opentelemetry (RubyGems): affected all versions; fixed in 0.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44163/ (Markdown: https://insights.sbomify.com/CVE-2026-44163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44163
- OSV: https://osv.dev/vulnerability/CVE-2026-44163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44163/
Summaries are generated and may contain mistakes; the official description above is the record.
