CVE-2026-44166 Pocketbase: Account pre-hijacking via OAuth2 unverfied->verified autolinking upgrade
Attackers can pre-hijack accounts by linking unverified OAuth2 profiles, allowing them to take over victim accounts when the victim signs up with a different provider.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-44166?
CVE-2026-44166 is a medium-severity authentication bypass vulnerability in pocketbase, published on 12 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Pocketbase is an open source web backend written in go. Prior to 0.22.42 and 0.37.4, in some situations, if an attacker knows the email address of the victim they can create and link an unverified PocketBase user in advance by authenticating with one of the OAuth2 app providers, e.g. "A". When the victim gets invited or decides to sign up to your app on their own with provider "B" (PocketBase OAuth2 auth requires to be with a different provider because we don't allow multiple OAuth2 accounts from the same provider to be associated to a single PocketBase user), the user created previously by the attacker will be autolinked, upgraded to "verified" and its old password reset. This vulnerability is fixed in 0.22.42 and 0.37.4.
Weakness: CWE-287
Which versions are affected by CVE-2026-44166?
5 open source packages ship an affected version, including github.com/pocketbase/pocketbase. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/pocketbase/pocketbase Go | All versions | 0.22.42, 0.37.4 |
github.com/pocketbase/pocketbase Go | All versions | 0.22.42 |
github.com/pocketbase/pocketbase Go | All versions | 0.22.42 |
github.com/pocketbase/pocketbase Go | From 0.30.0 | 0.37.4 |
github.com/pocketbase/pocketbase Go | From 0.30.0 | 0.37.4 |
Products include Pocketbase Pocketbase.
How do I fix CVE-2026-44166?
Upgrade github.com/pocketbase/pocketbase to a fixed version for your release line: 0.22.42 or 0.37.4.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-44166 being exploited?
There is no known exploitation of CVE-2026-44166 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as GHSA-pq7p-mc74-g65w, GO-2026-5548.