{"answers":{"affected":"5 open source packages ship an affected version, including github.com/pocketbase/pocketbase. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-44166 in the wild and no public exploit code.","fix":"Upgrade github.com/pocketbase/pocketbase to a fixed version for your release line: 0.22.42 or 0.37.4.","what":"CVE-2026-44166 is a medium-severity authentication bypass vulnerability in pocketbase, published on 12 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-44166 and fix it if it is affected.\n\nWhat it is: CVE-2026-44166 is a medium-severity authentication bypass vulnerability in pocketbase, published on 12 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-44166 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/pocketbase/pocketbase (Go): affected all versions; fixed in 0.22.42, 0.37.4\n- github.com/pocketbase/pocketbase (Go): affected all versions; fixed in 0.22.42\n- github.com/pocketbase/pocketbase (Go): affected all versions; fixed in 0.22.42\n- github.com/pocketbase/pocketbase (Go): affected from 0.30.0; fixed in 0.37.4\n- github.com/pocketbase/pocketbase (Go): affected from 0.30.0; fixed in 0.37.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44166/ (Markdown: https://insights.sbomify.com/CVE-2026-44166/index.md)","id":"CVE-2026-44166","markdown":"https://insights.sbomify.com/CVE-2026-44166/index.md","name":"CVE-2026-44166","record":{"aliases":["GHSA-pq7p-mc74-g65w","GO-2026-5548"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"PocketBase backend","requires_auth":"none","summary":"Attackers can pre-hijack accounts by linking unverified OAuth2 profiles, allowing them to take over victim accounts when the victim signs up with a different provider.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pocketbase","vendor":"pocketbase"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Pocketbase is an open source web backend written in go. Prior to 0.22.42 and 0.37.4, in some situations, if an attacker knows the email address of the victim they can create and link an unverified PocketBase user in advance by authenticating with one of the OAuth2 app providers, e.g. \"A\". When the victim gets invited or decides to sign up to your app on their own with provider \"B\" (PocketBase OAuth2 auth requires to be with a different provider because we don't allow multiple OAuth2 accounts from the same provider to be associated to a single PocketBase user), the user created previously by the attacker will be autolinked, upgraded to \"verified\" and its old password reset. This vulnerability is fixed in 0.22.42 and 0.37.4.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":"2026-06-11","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-06-11T02:06:40Z","kind":"github_poc","ref":"https://github.com/Alardiians/pocketbase-CVE-2026-44166","stars":0,"title":"Lab + writeup for CVE-2026-44166: PocketBase OAuth2 account pre-hijacking via unvalidated createData.email"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Pocketbase: Account pre-hijacking via OAuth2 unverfied-\u003everified autolinking upgrade","id":"CVE-2026-44166","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":5,"n_references":1,"next":{"headline":"phpseclib: CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()","id":"CVE-2026-44167"},"packages":[{"ecosystem":"Go","fixed":["0.22.42","0.37.4"],"introduced":["0","0.30.0"],"last_affected":[],"package":"github.com/pocketbase/pocketbase","purl":"pkg:golang/github.com/pocketbase/pocketbase","source":"GO-2026-5548"},{"ecosystem":"Go","fixed":["0.22.42"],"introduced":["0"],"last_affected":[],"package":"github.com/pocketbase/pocketbase","purl":null,"source":"GHSA-pq7p-mc74-g65w"},{"ecosystem":"Go","fixed":["0.22.42"],"introduced":["0"],"last_affected":[],"package":"github.com/pocketbase/pocketbase","purl":"pkg:golang/github.com/pocketbase/pocketbase","source":"GHSA-pq7p-mc74-g65w"},{"ecosystem":"Go","fixed":["0.37.4"],"introduced":["0.30.0"],"last_affected":[],"package":"github.com/pocketbase/pocketbase","purl":null,"source":"GHSA-pq7p-mc74-g65w"},{"ecosystem":"Go","fixed":["0.37.4"],"introduced":["0.30.0"],"last_affected":[],"package":"github.com/pocketbase/pocketbase","purl":"pkg:golang/github.com/pocketbase/pocketbase","source":"GHSA-pq7p-mc74-g65w"}],"prev":{"headline":"fluent-plugin-opentelemetry: Denial of Service (DoS) via Large Payloads and Decompression Bombs in `in_opentelemetry`","id":"CVE-2026-44163"},"products":["pocketbase"],"published":"2026-05-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-12","vendors":["pocketbase"]},"summary":"Attackers can pre-hijack accounts by linking unverified OAuth2 profiles, allowing them to take over victim accounts when the victim signs up with a different provider.","url":"https://insights.sbomify.com/CVE-2026-44166/"}