CVE-2026-44167 phpseclib: CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()
Attackers can cause denial of service in phpseclib by loading untrusted ASN1 files, bypassing previous mitigations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44167?
CVE-2026-44167 is a high-severity denial of service vulnerability in phpseclib, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a bypass of CVE-2024-27355. This vulnerability is fixed in 1.0.29, 2.0.54, and 3.0.52.
Weakness: CWE-400
Which versions are affected by CVE-2026-44167?
6 open source packages ship an affected version, including phpseclib/phpseclib.
| Package | Affected | Fixed in |
|---|---|---|
phpseclib/phpseclib Packagist | From 0.1.1 | 1.0.29 |
phpseclib/phpseclib Packagist | From 0.1.1 | 1.0.29 |
phpseclib/phpseclib Packagist | From 2.0.0 | 2.0.54 |
phpseclib/phpseclib Packagist | From 2.0.0 | 2.0.54 |
phpseclib/phpseclib Packagist | From 3.0.0 | 3.0.52 |
phpseclib/phpseclib Packagist | From 3.0.0 | 3.0.52 |
How do I fix CVE-2026-44167?
Upgrade phpseclib/phpseclib to a fixed version for your release line: 1.0.29, 2.0.54 or 3.0.52.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-44167 being exploited?
There is no known exploitation of CVE-2026-44167 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2026-44167, GHSA-3qpq-r242-jqj7, UBUNTU-CVE-2026-44167.