{"answers":{"affected":"6 open source packages ship an affected version, including phpseclib/phpseclib.","exploited":"There is no known exploitation of CVE-2026-44167 in the wild and no public exploit code.","fix":"Upgrade phpseclib/phpseclib to a fixed version for your release line: 1.0.29, 2.0.54 or 3.0.52.","what":"CVE-2026-44167 is a high-severity denial of service vulnerability in phpseclib, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44167 and fix it if it is affected.\n\nWhat it is: CVE-2026-44167 is a high-severity denial of service vulnerability in phpseclib, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44167 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpseclib/phpseclib (Packagist): affected from 0.1.1; fixed in 1.0.29\n- phpseclib/phpseclib (Packagist): affected from 0.1.1; fixed in 1.0.29\n- phpseclib/phpseclib (Packagist): affected from 2.0.0; fixed in 2.0.54\n- phpseclib/phpseclib (Packagist): affected from 2.0.0; fixed in 2.0.54\n- phpseclib/phpseclib (Packagist): affected from 3.0.0; fixed in 3.0.52\n- phpseclib/phpseclib (Packagist): affected from 3.0.0; fixed in 3.0.52\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44167/ (Markdown: https://insights.sbomify.com/CVE-2026-44167/index.md)","id":"CVE-2026-44167","markdown":"https://insights.sbomify.com/CVE-2026-44167/index.md","name":"CVE-2026-44167","record":{"aliases":["DEBIAN-CVE-2026-44167","GHSA-3qpq-r242-jqj7","UBUNTU-CVE-2026-44167"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP secure communications library","requires_auth":"none","summary":"Attackers can cause denial of service in phpseclib by loading untrusted ASN1 files, bypassing previous mitigations.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a bypass of CVE-2024-27355. This vulnerability is fixed in 1.0.29, 2.0.54, and 3.0.52.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpseclib: CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()","id":"CVE-2026-44167","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":6,"n_references":2,"next":{"headline":"MariaDB: wsrep SST unsafe parameter handling on the donor side","id":"CVE-2026-44168"},"packages":[{"ecosystem":"Packagist","fixed":["1.0.29"],"introduced":["0.1.1"],"last_affected":[],"package":"phpseclib/phpseclib","purl":null,"source":"GHSA-3qpq-r242-jqj7"},{"ecosystem":"Packagist","fixed":["1.0.29"],"introduced":["0.1.1"],"last_affected":[],"package":"phpseclib/phpseclib","purl":"pkg:composer/phpseclib/phpseclib","source":"GHSA-3qpq-r242-jqj7"},{"ecosystem":"Packagist","fixed":["2.0.54"],"introduced":["2.0.0"],"last_affected":[],"package":"phpseclib/phpseclib","purl":null,"source":"GHSA-3qpq-r242-jqj7"},{"ecosystem":"Packagist","fixed":["2.0.54"],"introduced":["2.0.0"],"last_affected":[],"package":"phpseclib/phpseclib","purl":"pkg:composer/phpseclib/phpseclib","source":"GHSA-3qpq-r242-jqj7"},{"ecosystem":"Packagist","fixed":["3.0.52"],"introduced":["3.0.0"],"last_affected":[],"package":"phpseclib/phpseclib","purl":null,"source":"GHSA-3qpq-r242-jqj7"},{"ecosystem":"Packagist","fixed":["3.0.52"],"introduced":["3.0.0"],"last_affected":[],"package":"phpseclib/phpseclib","purl":"pkg:composer/phpseclib/phpseclib","source":"GHSA-3qpq-r242-jqj7"}],"prev":{"headline":"Pocketbase: Account pre-hijacking via OAuth2 unverfied-\u003everified autolinking upgrade","id":"CVE-2026-44166"},"products":["phpseclib"],"published":"2026-05-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-14","vendors":["phpseclib"]},"summary":"Attackers can cause denial of service in phpseclib by loading untrusted ASN1 files, bypassing previous mitigations.","url":"https://insights.sbomify.com/CVE-2026-44167/"}