# CVE-2026-44167: phpseclib: CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()

> Attackers can cause denial of service in phpseclib by loading untrusted ASN1 files, bypassing previous mitigations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 14 May 2026
- **Also known as:** DEBIAN-CVE-2026-44167, GHSA-3qpq-r242-jqj7, UBUNTU-CVE-2026-44167

## What is CVE-2026-44167?

CVE-2026-44167 is a high-severity denial of service vulnerability in phpseclib, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a bypass of CVE-2024-27355. This vulnerability is fixed in 1.0.29, 2.0.54, and 3.0.52.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-44167?

6 open source packages ship an affected version, including phpseclib/phpseclib.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpseclib/phpseclib` | Packagist | From 0.1.1 | 1.0.29 |
| `phpseclib/phpseclib` | Packagist | From 0.1.1 | 1.0.29 |
| `phpseclib/phpseclib` | Packagist | From 2.0.0 | 2.0.54 |
| `phpseclib/phpseclib` | Packagist | From 2.0.0 | 2.0.54 |
| `phpseclib/phpseclib` | Packagist | From 3.0.0 | 3.0.52 |
| `phpseclib/phpseclib` | Packagist | From 3.0.0 | 3.0.52 |

## How do I fix CVE-2026-44167?

Upgrade phpseclib/phpseclib to a fixed version for your release line: 1.0.29, 2.0.54 or 3.0.52.

## Is CVE-2026-44167 being exploited?

There is no known exploitation of CVE-2026-44167 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44167 and fix it if it is affected.

What it is: CVE-2026-44167 is a high-severity denial of service vulnerability in phpseclib, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44167 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpseclib/phpseclib (Packagist): affected from 0.1.1; fixed in 1.0.29
- phpseclib/phpseclib (Packagist): affected from 0.1.1; fixed in 1.0.29
- phpseclib/phpseclib (Packagist): affected from 2.0.0; fixed in 2.0.54
- phpseclib/phpseclib (Packagist): affected from 2.0.0; fixed in 2.0.54
- phpseclib/phpseclib (Packagist): affected from 3.0.0; fixed in 3.0.52
- phpseclib/phpseclib (Packagist): affected from 3.0.0; fixed in 3.0.52

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44167/ (Markdown: https://insights.sbomify.com/CVE-2026-44167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44167
- OSV: https://osv.dev/vulnerability/CVE-2026-44167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44167/
Summaries are generated and may contain mistakes; the official description above is the record.
