# CVE-2026-44170: MariaDB: Argument injection in CONNECT REST Xcurl on Windows via unsanitized URL

> Attackers can execute shell commands on Windows MariaDB servers via unsanitized URLs in the CONNECT engine REST feature.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 3 Aug 2026
- **Also known as:** ALPINE-CVE-2026-44170, BELL-CVE-2026-44170, BIT-mariadb-2026-44170, BIT-mariadb-min-2026-44170, BIT-mysql-client-2026-44170, GHSA-f835-cfjq-wf73, MINI-fv35-q55m-25r2, MINI-gmg9-cjcg-7mq3, MINI-h56j-mq6r-27x3, MINI-q38x-xc62-gq3p, MINI-r7gj-gwm4-hcxc, MINI-x7xm-f6wx-5fxq, ROOT-OS-DEBIAN-13-CVE-2026-44170, UBUNTU-CVE-2026-44170

## What is CVE-2026-44170?

CVE-2026-44170 is a medium-severity command injection vulnerability in Mariadb Mariadb, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, MariaDB on WIndows with installed CONNECT engine and enabled REST support interpolated table HTTP attribute into the curl command line without proper sanitizing. This allows the user to execute shell commands on the server. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-44170?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | From 10.6.1 | 10.6.26, 10.11.17, 11.4.11, 11.8.7, 12.3.2 |
| `mariadb-min` | Bitnami | From 10.6.1 | 10.6.26, 10.11.17, 11.4.11, 11.8.7, 12.3.2 |
| `mysql-client` | Bitnami | From 10.6.1 | 10.6.26, 10.11.17, 11.4.11, 11.8.7, 12.3.2 |

Products: Mariadb Mariadb.

## How do I fix CVE-2026-44170?

Upgrade mariadb to a fixed version for your release line: 10.6.26, 10.11.17, 11.4.11 or 11.8.7.

## Is CVE-2026-44170 being exploited?

There is no known exploitation of CVE-2026-44170 in the wild and no public exploit code.

## Other vulnerabilities in Mariadb Mariadb

- [CVE-2026-49261](https://insights.sbomify.com/CVE-2026-49261/): MariaDB server has unsafe parameter handling in `wsrep_notify_cmd` (critical 10.0)
- [CVE-2026-85746](https://insights.sbomify.com/CVE-2026-85746/): MariaDB: Out-of-bound buffer write on in `ST_AsText` of nested GeometryCollections (critical 9.9)
- [CVE-2026-85748](https://insights.sbomify.com/CVE-2026-85748/): MariaDB: Use-after-free with a large number of SYS_REFCURSOR's (critical 9.9)
- [CVE-2026-92262](https://insights.sbomify.com/CVE-2026-92262/): MariaDB: Numerous issues caused by historical #mysql50# tablename encoding bypass. (critical 9.9)
- [CVE-2023-26785](https://insights.sbomify.com/CVE-2023-26785/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44170 and fix it if it is affected.

What it is: CVE-2026-44170 is a medium-severity command injection vulnerability in Mariadb Mariadb, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44170 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected from 10.6.1; fixed in 10.6.26, 10.11.17, 11.4.11, 11.8.7, 12.3.2
- mariadb-min (Bitnami): affected from 10.6.1; fixed in 10.6.26, 10.11.17, 11.4.11, 11.8.7, 12.3.2
- mysql-client (Bitnami): affected from 10.6.1; fixed in 10.6.26, 10.11.17, 11.4.11, 11.8.7, 12.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44170/ (Markdown: https://insights.sbomify.com/CVE-2026-44170/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44170
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44170
- OSV: https://osv.dev/vulnerability/CVE-2026-44170

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44170/
Summaries are generated and may contain mistakes; the official description above is the record.
