# CVE-2026-44171: MariaDB: path traversal in mbstream

> A path traversal vulnerability in MariaDB's mbstream allows attackers to write files outside the target directory using a crafted archive.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** ALPINE-CVE-2026-44171, BELL-CVE-2026-44171, BIT-mariadb-2026-44171, BIT-mariadb-min-2026-44171, BIT-mysql-client-2026-44171, CLSA-2026-1786548808, DEBIAN-CVE-2026-44171, ECHO-2251-f2e7-9c06, GHSA-9pjh-5hhw-65v9, MINI-6x2c-57mp-jmfc, MINI-72pw-875v-cj6g, MINI-c654-x58x-68r8, MINI-mj53-frc2-7qw9, MINI-qqxv-9hrj-7r2j, MINI-r4xh-34w6-fgrv, ROOT-OS-DEBIAN-13-CVE-2026-44171, UBUNTU-CVE-2026-44171

## What is CVE-2026-44171?

CVE-2026-44171 is a medium-severity path traversal vulnerability in Mariadb Mariadb, published on 12 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, mbstream did not check for /../ in the path when unpacking the archive. A proper backup can never contain such paths, but a specially crafted archive could have caused mbstream to create files outside of the target-dir path. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-44171?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | From 10.6.1 | 10.6.26, 10.11.17, 11.4.11, 11.8.7, 12.3.2 |
| `mariadb-min` | Bitnami | From 10.6.1 | 10.6.26, 10.11.17, 11.4.11, 11.8.7, 12.3.2 |
| `mysql-client` | Bitnami | From 10.6.1 | 10.6.26, 10.11.17, 11.4.11, 11.8.7, 12.3.2 |

Products: Mariadb Mariadb.

## How do I fix CVE-2026-44171?

Upgrade mariadb to a fixed version for your release line: 10.6.26, 10.11.17, 11.4.11 or 11.8.7.

## Is CVE-2026-44171 being exploited?

There is no known exploitation of CVE-2026-44171 in the wild and no public exploit code.

## Other vulnerabilities in Mariadb Mariadb

- [CVE-2026-49261](https://insights.sbomify.com/CVE-2026-49261/): MariaDB server has unsafe parameter handling in `wsrep_notify_cmd` (critical 10.0)
- [CVE-2026-85746](https://insights.sbomify.com/CVE-2026-85746/): MariaDB: Out-of-bound buffer write on in `ST_AsText` of nested GeometryCollections (critical 9.9)
- [CVE-2026-85748](https://insights.sbomify.com/CVE-2026-85748/): MariaDB: Use-after-free with a large number of SYS_REFCURSOR's (critical 9.9)
- [CVE-2026-92262](https://insights.sbomify.com/CVE-2026-92262/): MariaDB: Numerous issues caused by historical #mysql50# tablename encoding bypass. (critical 9.9)
- [CVE-2023-26785](https://insights.sbomify.com/CVE-2023-26785/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44171 and fix it if it is affected.

What it is: CVE-2026-44171 is a medium-severity path traversal vulnerability in Mariadb Mariadb, published on 12 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-44171 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected from 10.6.1; fixed in 10.6.26, 10.11.17, 11.4.11, 11.8.7, 12.3.2
- mariadb-min (Bitnami): affected from 10.6.1; fixed in 10.6.26, 10.11.17, 11.4.11, 11.8.7, 12.3.2
- mysql-client (Bitnami): affected from 10.6.1; fixed in 10.6.26, 10.11.17, 11.4.11, 11.8.7, 12.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44171/ (Markdown: https://insights.sbomify.com/CVE-2026-44171/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44171
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44171
- OSV: https://osv.dev/vulnerability/CVE-2026-44171

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44171/
Summaries are generated and may contain mistakes; the official description above is the record.
