# CVE-2026-44174: Kirby: Arbitrary Method Call via REST API search and collection query endpoints

> Attackers can invoke arbitrary model methods via REST API queries, leading to privilege escalation, data disclosure, or data deletion in Kirby CMS.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 18 Jul 2026
- **Also known as:** GHSA-86rh-h242-j8xp

## What is CVE-2026-44174?

CVE-2026-44174 is a high-severity code injection vulnerability in getkirby kirby, published on 16 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kirby is an open-source content management system. Prior to 4.9.1 and 5.4.1, Kirby did not validate the model attributes that were used in its collection queries, allowing attackers to include arbitrary model methods in their queries. This includes methods with sensitive data such as password() (disclosing the password hash) or root() (disclosing the absolute filesystem path on the server) as well as methods that perform impactful actions such as loginPasswordless() (causing a privilege escalation to another user) or delete() (deleting all queried models in one go if the authenticated user has appropriate permissions). This issue has been fixed in versions 4.9.1 and 5.4.1.

Weakness: CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2026-44174?

4 open source packages ship an affected version, including getkirby/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 4.9.1 |
| `getkirby/cms` | Packagist | All versions | 4.9.1 |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.4.1 |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.4.1 |

## How do I fix CVE-2026-44174?

Upgrade getkirby/cms to a fixed version for your release line: 4.9.1 or 5.4.1.

## Is CVE-2026-44174 being exploited?

There is no known exploitation of CVE-2026-44174 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44174 and fix it if it is affected.

What it is: CVE-2026-44174 is a high-severity code injection vulnerability in getkirby kirby, published on 16 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44174 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.1
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.1
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.4.1
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44174/ (Markdown: https://insights.sbomify.com/CVE-2026-44174/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44174
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44174
- OSV: https://osv.dev/vulnerability/CVE-2026-44174

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44174/
Summaries are generated and may contain mistakes; the official description above is the record.
