CVE-2026-44175 Kirby: Cross-site scripting (XSS) from list field content in the site frontend
Attackers can inject malicious HTML via the list field API, leading to persistent XSS and potential account takeover for site visitors and admins.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-44175?
CVE-2026-44175 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 16 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Kirby is an open-source content management system. In versions prior to 4.9.1 and 5.4.1, Kirby did not securely sanitize the contents of the list field on save, leaving it vulnerable to cross-site scripting (XSS). Kirby's list field stores its formatted content as HTML, and unlike other field types, its HTML special characters cannot be escaped without losing the formatting. Sanitization was only enforced client-side in the Panel, while the server did not sanitize the content on save. As a result, an attacker could bypass the Panel and send malicious HTML directly to Kirby's API, storing unsanitized markup in the content file. That markup would then be rendered on the site frontend and executed in the browsers of site visitors and logged-in users browsing the site, resulting in persistent XSS. This issue has been fixed in versions 4.9.1 and 5.4.1.
Weakness: CWE-79
Which versions are affected by CVE-2026-44175?
4 open source packages ship an affected version, including getkirby/cms.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 4.9.1 |
getkirby/cms Packagist | All versions | 4.9.1 |
getkirby/cms Packagist | From 5.0.0 | 5.4.1 |
getkirby/cms Packagist | From 5.0.0 | 5.4.1 |
How do I fix CVE-2026-44175?
Upgrade getkirby/cms to a fixed version for your release line: 4.9.1 or 5.4.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-44175 being exploited?
There is no known exploitation of CVE-2026-44175 in the wild and no public exploit code.
Sources
Also known as GHSA-5fhx-9q32-q257.