CVE-2026-44176 Kirby: `pages.access` permission is not checked during rendering of page drafts
Authenticated attackers can access unauthorized page drafts by bypassing access permission checks, leading to sensitive information disclosure.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44176?
CVE-2026-44176 is a medium-severity missing authorization vulnerability in getkirby kirby, published on 16 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Kirby is an open-source content management system. Versions prior to 4.9.1 and 5.4.1 do not check the `pages.access` permission during page draft rendering. Permissions are defined for each user role in the user blueprint (site/blueprints/users/...). It is also possible to customize the permissions for each target model in the model blueprints (such as in site/blueprints/pages/...) using the options feature. The permissions and options together control the authorization of user actions. Kirby provides the pages.access and pages.list permissions (among others). The list permission controls whether affected models appear in lists throughout the Panel and REST API. The access permission has the same effect but also disables direct access to the affected models. This vulnerability affects the path resolver for the main CMS router. The resolver takes an input path from the requested URL and determines which model (page or file) should be rendered. When a path is requested that points to a page draft, the resolver checks that the request either contains a valid preview token or is authenticated by a valid user. In affected releases, Kirby allowed page drafts to be rendered if any valid user was authenticated, even if that user did not have access to the specific page model. Authenticated attackers with knowledge of the full path to an existing page draft could then access the rendered frontend page. This could lead to the disclosure of sensitive information, e.g. ahead of the launch of a new product or post. This issue has been fixed in versions 4.9.1 and 5.4.1.
Weakness: CWE-862
Which versions are affected by CVE-2026-44176?
4 open source packages ship an affected version, including getkirby/cms.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 4.9.1 |
getkirby/cms Packagist | All versions | 4.9.1 |
getkirby/cms Packagist | From 5.0.0 | 5.4.1 |
getkirby/cms Packagist | From 5.0.0 | 5.4.1 |
How do I fix CVE-2026-44176?
Upgrade getkirby/cms to a fixed version for your release line: 4.9.1 or 5.4.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-44176 being exploited?
There is no known exploitation of CVE-2026-44176 in the wild and no public exploit code.
Sources
Also known as GHSA-2xw4-v2wx-hqq9.