# CVE-2026-44176: Kirby: `pages.access` permission is not checked during rendering of page drafts

> Authenticated attackers can access unauthorized page drafts by bypassing access permission checks, leading to sensitive information disclosure.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** GHSA-2xw4-v2wx-hqq9

## What is CVE-2026-44176?

CVE-2026-44176 is a medium-severity missing authorization vulnerability in getkirby kirby, published on 16 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kirby is an open-source content management system. Versions prior to 4.9.1 and 5.4.1 do not check the `pages.access` permission  during page draft rendering. Permissions are defined for each user role in the user blueprint (site/blueprints/users/...). It is also possible to customize the permissions for each target model in the model blueprints (such as in site/blueprints/pages/...) using the options feature. The permissions and options together control the authorization of user actions. Kirby provides the pages.access and pages.list permissions (among others). The list permission controls whether affected models appear in lists throughout the Panel and REST API. The access permission has the same effect but also disables direct access to the affected models. This vulnerability affects the path resolver for the main CMS router. The resolver takes an input path from the requested URL and determines which model (page or file) should be rendered. When a path is requested that points to a page draft, the resolver checks that the request either contains a valid preview token or is authenticated by a valid user. In affected releases, Kirby allowed page drafts to be rendered if any valid user was authenticated, even if that user did not have access to the specific page model. Authenticated attackers with knowledge of the full path to an existing page draft could then access the rendered frontend page. This could lead to the disclosure of sensitive information, e.g. ahead of the launch of a new product or post. This issue has been fixed in versions 4.9.1 and 5.4.1.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-44176?

4 open source packages ship an affected version, including getkirby/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 4.9.1 |
| `getkirby/cms` | Packagist | All versions | 4.9.1 |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.4.1 |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.4.1 |

## How do I fix CVE-2026-44176?

Upgrade getkirby/cms to a fixed version for your release line: 4.9.1 or 5.4.1.

## Is CVE-2026-44176 being exploited?

There is no known exploitation of CVE-2026-44176 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44176 and fix it if it is affected.

What it is: CVE-2026-44176 is a medium-severity missing authorization vulnerability in getkirby kirby, published on 16 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44176 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.1
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.1
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.4.1
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44176/ (Markdown: https://insights.sbomify.com/CVE-2026-44176/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44176
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44176
- OSV: https://osv.dev/vulnerability/CVE-2026-44176

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44176/
Summaries are generated and may contain mistakes; the official description above is the record.
