CVE-2026-44177 Kirby: Pre-authentication path traversal and PHP file inclusion during user lookup

High 8.8 Published Updated

Unauthenticated attackers can exploit path traversal in user lookup to include arbitrary PHP files, potentially executing code or revealing server structure.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-44177?

CVE-2026-44177 is a high-severity path traversal vulnerability in getkirby kirby, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Kirby is an open-source content management system. In versions 5.3.0 and above but prior to 5.4.1, Kirby did not correctly validate the provided user ID, resulting in a path traversal vulnerability. Version 5.3.0 introduced a performance improvement to the Users collection that loaded user objects lazily when first needed. Users were queried by their ID, which was then used to locate the corresponding account directory under site/accounts. This affected the authentication API (accessible to unauthenticated requests), the users API (accessible only to authenticated users), and any other place that uses $users->find() to look up an individual user by a request-provided email or ID. As a result, an attacker could trigger arbitrary PHP file inclusion of files named  index.php (for example, the main PHP files of plugins), the impact of which depends on the logic those files contain. It also allowed probing for the existence of arbitrary directories on the server, letting attackers fingerprint the server and site setup, including installed plugins and the content structure. This issue has been fixed in version 5.4.1.

Weakness: CWE-98, CWE-22

Which versions are affected by CVE-2026-44177?

2 open source packages ship an affected version, including getkirby/cms.

PackageAffectedFixed in
getkirby/cms PackagistFrom 5.3.05.4.1
getkirby/cms PackagistFrom 5.3.05.4.1

How do I fix CVE-2026-44177?

Upgrade getkirby/cms to 5.4.1 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-44177 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44177 exists.

Public exploit code: 1 Nuclei template.

Sources

Also known as GHSA-9hx7-c53c-v6x8.

Is CVE-2026-44177 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free