{"answers":{"affected":"2 open source packages ship an affected version, including getkirby/cms.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44177 exists.","fix":"Upgrade getkirby/cms to 5.4.1 or later.","what":"CVE-2026-44177 is a high-severity path traversal vulnerability in getkirby kirby, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44177 and fix it if it is affected.\n\nWhat it is: CVE-2026-44177 is a high-severity path traversal vulnerability in getkirby kirby, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44177 exists.\n\nAffected packages and fixed versions:\n- getkirby/cms (Packagist): affected from 5.3.0; fixed in 5.4.1\n- getkirby/cms (Packagist): affected from 5.3.0; fixed in 5.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44177/ (Markdown: https://insights.sbomify.com/CVE-2026-44177/index.md)","id":"CVE-2026-44177","markdown":"https://insights.sbomify.com/CVE-2026-44177/index.md","name":"CVE-2026-44177","record":{"aliases":["GHSA-9hx7-c53c-v6x8"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Kirby CMS","requires_auth":"none","summary":"Unauthenticated attackers can exploit path traversal in user lookup to include arbitrary PHP files, potentially executing code or revealing server structure.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-98","name":"Improper Control of Filename for Include/Require Statement in PHP Program"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Kirby is an open-source content management system. In versions 5.3.0 and above but prior to 5.4.1, Kirby did not correctly validate the provided user ID, resulting in a path traversal vulnerability. Version 5.3.0 introduced a performance improvement to the Users collection that loaded user objects lazily when first needed. Users were queried by their ID, which was then used to locate the corresponding account directory under site/accounts. This affected the authentication API (accessible to unauthenticated requests), the users API (accessible only to authenticated users), and any other place that uses $users-\u003efind() to look up an individual user by a request-provided email or ID. As a result, an attacker could trigger arbitrary PHP file inclusion of files named  index.php (for example, the main PHP files of plugins), the impact of which depends on the logic those files contain. It also allowed probing for the existence of arbitrary directories on the server, letting attackers fingerprint the server and site setup, including installed plugins and the content structure. This issue has been fixed in version 5.4.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2026/CVE-2026-44177.yaml","stars":null,"title":"Kirby CMS 5.3.0-5.4.0 - Path Traversal"}],"tier":"weaponised"},"has_fix":true,"headline":"Kirby: Pre-authentication path traversal and PHP file inclusion during user lookup","id":"CVE-2026-44177","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"xrdp: Channel Data Forwarding Fixed-Size Buffer Overflow","id":"CVE-2026-44178"},"packages":[{"ecosystem":"Packagist","fixed":["5.4.1"],"introduced":["5.3.0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-9hx7-c53c-v6x8"},{"ecosystem":"Packagist","fixed":["5.4.1"],"introduced":["5.3.0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-9hx7-c53c-v6x8"}],"prev":{"headline":"Kirby: `pages.access` permission is not checked during rendering of page drafts","id":"CVE-2026-44176"},"products":["kirby"],"published":"2026-07-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-17","vendors":["getkirby"]},"summary":"Unauthenticated attackers can exploit path traversal in user lookup to include arbitrary PHP files, potentially executing code or revealing server structure.","url":"https://insights.sbomify.com/CVE-2026-44177/"}