# CVE-2026-44177: Kirby: Pre-authentication path traversal and PHP file inclusion during user lookup

> Unauthenticated attackers can exploit path traversal in user lookup to include arbitrary PHP files, potentially executing code or revealing server structure.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** GHSA-9hx7-c53c-v6x8

## What is CVE-2026-44177?

CVE-2026-44177 is a high-severity path traversal vulnerability in getkirby kirby, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kirby is an open-source content management system. In versions 5.3.0 and above but prior to 5.4.1, Kirby did not correctly validate the provided user ID, resulting in a path traversal vulnerability. Version 5.3.0 introduced a performance improvement to the Users collection that loaded user objects lazily when first needed. Users were queried by their ID, which was then used to locate the corresponding account directory under site/accounts. This affected the authentication API (accessible to unauthenticated requests), the users API (accessible only to authenticated users), and any other place that uses $users->find() to look up an individual user by a request-provided email or ID. As a result, an attacker could trigger arbitrary PHP file inclusion of files named  index.php (for example, the main PHP files of plugins), the impact of which depends on the logic those files contain. It also allowed probing for the existence of arbitrary directories on the server, letting attackers fingerprint the server and site setup, including installed plugins and the content structure. This issue has been fixed in version 5.4.1.

Weakness: CWE-98 (Improper Control of Filename for Include/Require Statement in PHP Program), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-44177?

2 open source packages ship an affected version, including getkirby/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | From 5.3.0 | 5.4.1 |
| `getkirby/cms` | Packagist | From 5.3.0 | 5.4.1 |

## How do I fix CVE-2026-44177?

Upgrade getkirby/cms to 5.4.1 or later.

## Is CVE-2026-44177 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44177 exists.

Public exploit code:

- Kirby CMS 5.3.0-5.4.0 - Path Traversal (nuclei): http/cves/2026/CVE-2026-44177.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44177 and fix it if it is affected.

What it is: CVE-2026-44177 is a high-severity path traversal vulnerability in getkirby kirby, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44177 exists.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected from 5.3.0; fixed in 5.4.1
- getkirby/cms (Packagist): affected from 5.3.0; fixed in 5.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44177/ (Markdown: https://insights.sbomify.com/CVE-2026-44177/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44177
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44177
- OSV: https://osv.dev/vulnerability/CVE-2026-44177

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44177/
Summaries are generated and may contain mistakes; the official description above is the record.
