CVE-2026-44180 Jupyter Enterprise Gateway: ContainerProcessProxy._enforce_prohibited_ids can be Bypassed

Critical 9.8 Published Updated

Attackers can bypass UID/GID restrictions to run Jupyter kernels as root, potentially leading to container escapes and cluster compromise.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-44180?

CVE-2026-44180 is a critical vulnerability in jupyter-server enterprise_gateway, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Jupyter Enterprise Gateway launches remote Jupyter Notebook kernels across distributed clusters like Apache Spark, Kubernetes, and Docker Swarm. Versions 2.0.0rc1 and above prior to 3.3.0 have a prohibited UID and GID feature that by default prevents launching kernels with UID or GID 0 (root), and this restriction can be bypassed using a specially crafted KERNEL_UID or KERNEL_GID value. This input validation vulnerability allows running Jupyter kernels as root, which can be dangerous as it allows more attack surface, and may lead to container escapes, compromising the worker node and all workloads running on it. Repeated exploitation can compromise all worker nodes, and thus the entire Kubernetes cluster. It is possible to specify volume mounts, so one vector for a container escape is to use a hostPath R/W volume mount, use this UID/GID bypass to run as root, and then gain code execution in the underlying worker node by creating a crontab entry in the mounted host file system. This issue has been fixed in version 3.0.0.

Weakness: CWE-20

Which versions are affected by CVE-2026-44180?

3 open source packages ship an affected version, including jupyter_enterprise_gateway and jupyter-enterprise-gateway. It affects 1 product.

PackageAffectedFixed in
jupyter_enterprise_gateway PyPIFrom 2.0.0rc13.3.0
jupyter-enterprise-gateway PyPIFrom 2.0.0rc13.3.0
jupyter-enterprise-gateway PyPIFrom 2.0.0rc13.3.0

Products include Jupyter Enterprise Gateway.

How do I fix CVE-2026-44180?

Upgrade jupyter_enterprise_gateway to 3.3.0 or later.

Is CVE-2026-44180 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44180 exists.

Sources

Also known as GHSA-chq7-94j8-cj28, PYSEC-2026-363.

Is CVE-2026-44180 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free