# CVE-2026-44180: Jupyter Enterprise Gateway: ContainerProcessProxy._enforce_prohibited_ids can be Bypassed

> Attackers can bypass UID/GID restrictions to run Jupyter kernels as root, potentially leading to container escapes and cluster compromise.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** GHSA-chq7-94j8-cj28, PYSEC-2026-363

## What is CVE-2026-44180?

CVE-2026-44180 is a critical vulnerability in jupyter-server enterprise_gateway, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jupyter Enterprise Gateway launches remote Jupyter Notebook kernels across distributed clusters like Apache Spark, Kubernetes, and Docker Swarm. Versions 2.0.0rc1 and above prior to 3.3.0 have a prohibited UID and GID feature that by default prevents launching kernels with UID or GID 0 (root), and this restriction can be bypassed using a specially crafted KERNEL_UID or KERNEL_GID value. This input validation vulnerability allows running Jupyter kernels as root, which can be dangerous as it allows more attack surface, and may lead to container escapes, compromising the worker node and all workloads running on it. Repeated exploitation can compromise all worker nodes, and thus the entire Kubernetes cluster. It is possible to specify volume mounts, so one vector for a container escape is to use a hostPath R/W volume mount, use this UID/GID bypass to run as root, and then gain code execution in the underlying worker node by creating a crontab entry in the mounted host file system. This issue has been fixed in version 3.0.0.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-44180?

3 open source packages ship an affected version, including jupyter_enterprise_gateway and jupyter-enterprise-gateway. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter_enterprise_gateway` | PyPI | From 2.0.0rc1 | 3.3.0 |
| `jupyter-enterprise-gateway` | PyPI | From 2.0.0rc1 | 3.3.0 |
| `jupyter-enterprise-gateway` | PyPI | From 2.0.0rc1 | 3.3.0 |

Products: Jupyter Enterprise Gateway.

## How do I fix CVE-2026-44180?

Upgrade jupyter_enterprise_gateway to 3.3.0 or later.

## Is CVE-2026-44180 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44180 exists.

## Other vulnerabilities in jupyter-server enterprise_gateway

- [CVE-2026-44181](https://insights.sbomify.com/CVE-2026-44181/): Jupyter Enterprise Gateway: Jinja2 Template Server Side Template Injection results in Remote Code Execution (critical 10.0)
- [CVE-2026-44182](https://insights.sbomify.com/CVE-2026-44182/): Jupyter Enterprise Gateway Has Kubernetes Manifest Injection via Jinja2 Template Rendering (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44180 and fix it if it is affected.

What it is: CVE-2026-44180 is a critical vulnerability in jupyter-server enterprise_gateway, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44180 exists.

Affected packages and fixed versions:
- jupyter_enterprise_gateway (PyPI): affected from 2.0.0rc1; fixed in 3.3.0
- jupyter-enterprise-gateway (PyPI): affected from 2.0.0rc1; fixed in 3.3.0
- jupyter-enterprise-gateway (PyPI): affected from 2.0.0rc1; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44180/ (Markdown: https://insights.sbomify.com/CVE-2026-44180/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44180
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44180
- OSV: https://osv.dev/vulnerability/CVE-2026-44180

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44180/
Summaries are generated and may contain mistakes; the official description above is the record.
