# CVE-2026-44182: Jupyter Enterprise Gateway Has Kubernetes Manifest Injection via Jinja2 Template Rendering

> Attackers can inject YAML into Kubernetes manifests via untrusted environment variables to create privileged pods, requiring an upgrade to Jupyter Enterprise Gateway.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** GHSA-cfw7-6c5v-2wjq, PYSEC-2026-362

## What is CVE-2026-44182?

CVE-2026-44182 is a critical code injection vulnerability in jupyter-server enterprise_gateway, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jupyter Enterprise Gateway launches remote Jupyter Notebook kernels across distributed clusters like Apache Spark, Kubernetes, and Docker Swarm. In versions prior to 3.3.0, the server interpolates untrusted environment variables (e.g., KERNEL_XXX) into Kubernetes manifests without YAML-aware escaping, enabling YAML injection attacks. Attackers can inject new fields, overwrite critical fields (e.g., duplicate securityContext keys, where the last one prevails), and inject document boundaries (--- for new documents, ... for end-of-document) to generate multiple resources, potentially creating arbitrary types, such as privileged pods. The Jinja2 template for the Kubernetes manifest contains several kernel_xxx variables, such as kernel_working_dir that are used when rendering the manifest and are all vectors for YAML injection. This issue has been fixed in version 3.3.0.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-44182?

3 open source packages ship an affected version, including jupyter_enterprise_gateway and jupyter-enterprise-gateway. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter_enterprise_gateway` | PyPI | All versions | 3.3.0 |
| `jupyter-enterprise-gateway` | PyPI | All versions | 3.3.0 |
| `jupyter-enterprise-gateway` | PyPI | All versions | 3.3.0 |

Products: Jupyter Enterprise Gateway.

## How do I fix CVE-2026-44182?

Upgrade jupyter_enterprise_gateway to 3.3.0 or later.

## Is CVE-2026-44182 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44182 exists.

## Other vulnerabilities in jupyter-server enterprise_gateway

- [CVE-2026-44181](https://insights.sbomify.com/CVE-2026-44181/): Jupyter Enterprise Gateway: Jinja2 Template Server Side Template Injection results in Remote Code Execution (critical 10.0)
- [CVE-2026-44180](https://insights.sbomify.com/CVE-2026-44180/): Jupyter Enterprise Gateway: ContainerProcessProxy._enforce_prohibited_ids can be Bypassed (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44182 and fix it if it is affected.

What it is: CVE-2026-44182 is a critical code injection vulnerability in jupyter-server enterprise_gateway, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44182 exists.

Affected packages and fixed versions:
- jupyter_enterprise_gateway (PyPI): affected all versions; fixed in 3.3.0
- jupyter-enterprise-gateway (PyPI): affected all versions; fixed in 3.3.0
- jupyter-enterprise-gateway (PyPI): affected all versions; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44182/ (Markdown: https://insights.sbomify.com/CVE-2026-44182/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44182
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44182
- OSV: https://osv.dev/vulnerability/CVE-2026-44182

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44182/
Summaries are generated and may contain mistakes; the official description above is the record.
