CVE-2026-44185 Apache HTTP Server: Stack Buffer Over-Read in mod_ssl OCSP `send_request`
An attacker controlling an OCSP server can trigger a stack buffer over-read in Apache HTTP Server, potentially causing crashes or leaking memory.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44185?
CVE-2026-44185 is a high-severity memory corruption vulnerability in Apache Http Server, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Buffer Over-read vulnerability in Apache HTTP Server via outbound OCSP requests to an attacker controlled OCSP server
This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.
Users are recommended to upgrade to version 2.4.68, which fixes the issue.
Which versions are affected by CVE-2026-44185?
1 open source package ship an affected version, including apache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.0 | 2.4.68 |
Products include Apache Http Server.
How do I fix CVE-2026-44185?
Upgrade apache to 2.4.68 or later.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-44185 being exploited?
There is no known exploitation of CVE-2026-44185 in the wild and no public exploit code.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2026-44185, AZL-89747, BELL-CVE-2026-44185, BIT-apache-2026-44185, CLSA-2026-1782137198, CLSA-2026-1782224876 and 9 more.