CVE-2026-44186 Apache HTTP Server: Loop in `proxy_ftp_handler` in mod_proxy_ftp

High 7.3 Published Updated

An infinite loop in mod_proxy_ftp allows attackers to cause denial of service via a malicious backend FTP server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-44186?

CVE-2026-44186 is a high-severity denial of service vulnerability in Apache Http Server, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in the mod_proxy_ftp module in Apache HTTP Server with an attacker controlled backend FTP server.

This issue affects undefined: from 2.4.0 through 2.4.67.

Users are recommended to upgrade to version 2.4.68, which fixes the issue.

Weakness: CWE-835

Which versions are affected by CVE-2026-44186?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiFrom 2.4.02.4.68

Products include Apache Http Server.

How do I fix CVE-2026-44186?

Upgrade apache to 2.4.68 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-44186 being exploited?

There is no known exploitation of CVE-2026-44186 in the wild and no public exploit code.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2026-44186, AZL-89741, BELL-CVE-2026-44186, BIT-apache-2026-44186, CLSA-2026-1782144906, CLSA-2026-1782153378 and 10 more.

Is CVE-2026-44186 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free