{"answers":{"affected":"1 open source package ship an affected version, including apache. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-44186 in the wild and no public exploit code.","fix":"Upgrade apache to 2.4.68 or later.","what":"CVE-2026-44186 is a high-severity denial of service vulnerability in Apache Http Server, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44186 and fix it if it is affected.\n\nWhat it is: CVE-2026-44186 is a high-severity denial of service vulnerability in Apache Http Server, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44186 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache (Bitnami): affected from 2.4.0; fixed in 2.4.68\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44186/ (Markdown: https://insights.sbomify.com/CVE-2026-44186/index.md)","id":"CVE-2026-44186","markdown":"https://insights.sbomify.com/CVE-2026-44186/index.md","name":"CVE-2026-44186","record":{"aliases":["ALPINE-CVE-2026-44186","AZL-89741","BELL-CVE-2026-44186","BIT-apache-2026-44186","CLSA-2026-1782144906","CLSA-2026-1782153378","CLSA-2026-1782160246","CLSA-2026-1782160524","CLSA-2026-1782987193","CLSA-2026-1783698569","CLSA-2026-1786004455","DEBIAN-CVE-2026-44186","ECHO-16e4-ffac-d93d","GHSA-6cr8-qx2w-7743","MINI-rmw7-vwxr-j39v","UBUNTU-CVE-2026-44186"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache HTTP Server","requires_auth":"none","summary":"An infinite loop in mod_proxy_ftp allows attackers to cause denial of service via a malicious backend FTP server.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"}],"cvss":{"score":7.3,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in the mod_proxy_ftp module in Apache HTTP Server with an attacker controlled backend FTP server.\n\nThis issue affects undefined: from 2.4.0 through 2.4.67.\n\nUsers are recommended to upgrade to version 2.4.68, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache HTTP Server: Loop in `proxy_ftp_handler` in mod_proxy_ftp","id":"CVE-2026-44186","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:http_server","products":["apache:http_server"],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Information disclosure in Red Hat Ansible Automation Platform 2","id":"CVE-2026-44187"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.68"],"introduced":["2.4.0"],"last_affected":[],"package":"apache","purl":"pkg:bitnami/apache","source":"BIT-apache-2026-44186"}],"prev":{"headline":"Apache HTTP Server: Stack Buffer Over-Read in mod_ssl OCSP `send_request`","id":"CVE-2026-44185"},"products":["Apache HTTP Server"],"published":"2026-06-08","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-09","vendors":["Apache Software Foundation"]},"summary":"An infinite loop in mod_proxy_ftp allows attackers to cause denial of service via a malicious backend FTP server.","url":"https://insights.sbomify.com/CVE-2026-44186/"}