{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44194 exists.","fix":"No fix has been published for CVE-2026-44194 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-44194 is a critical command injection vulnerability in opnsense core, published on 13 May 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44194 and fix it if it is affected.\n\nWhat it is: CVE-2026-44194 is a critical command injection vulnerability in opnsense core, published on 13 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44194 exists.\n\nAffected product: opnsense core. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44194/ (Markdown: https://insights.sbomify.com/CVE-2026-44194/index.md)","id":"CVE-2026-44194","markdown":"https://insights.sbomify.com/CVE-2026-44194/index.md","name":"CVE-2026-44194","record":{"aliases":["GHSA-f59w-m967-9rf6"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"OPNsense firewall","requires_auth":"high_privilege","summary":"Authenticated users with management privileges can execute arbitrary root commands via crafted email inputs in the user synchronization script.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"opnsense","vendor":"opnsense"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.8, an authenticated Remote Code Execution (RCE) vulnerability in the OPNsense core allows a user with user-management privileges to execute arbitrary system commands as root. An attacker can bypass input validation by formatting their malicious payload as a compliant email address, allowing shell commands to reach the underlying operating system. The flaw exists in the local user synchronization flow, within core/src/opnsense/scripts/auth/sync_user.php. This vulnerability is fixed in 26.1.8.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"OPNsense: RCE on user managment","id":"CVE-2026-44194","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"OPNsense: Authentication lockout bypass","id":"CVE-2026-44195"},"packages":[],"prev":{"headline":"OPNsense: RCE via XMLRPC endpoint using `opnsense.restore_config_section` method","id":"CVE-2026-44193"},"products":["core"],"published":"2026-05-13","related":[{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2023-27152","kev_date_added":null,"published":"2023-10-23"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2023-39001","kev_date_added":null,"published":"2023-08-09"},{"cvss_score":9.8,"headline":"Information disclosure in n/a","id":"CVE-2023-39004","kev_date_added":null,"published":"2023-08-09"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2023-39008","kev_date_added":null,"published":"2023-08-09"},{"cvss_score":9.6,"headline":"Cross-site scripting in n/a","id":"CVE-2023-39007","kev_date_added":null,"published":"2023-08-09"},{"cvss_score":9.1,"headline":"OPNsense: RCE via XMLRPC endpoint using `opnsense.restore_config_section` method","id":"CVE-2026-44193","kev_date_added":null,"published":"2026-05-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-19","vendors":["opnsense"]},"summary":"Authenticated users with management privileges can execute arbitrary root commands via crafted email inputs in the user synchronization script.","url":"https://insights.sbomify.com/CVE-2026-44194/"}