# CVE-2026-44194: OPNsense: RCE on user managment

> Authenticated users with management privileges can execute arbitrary root commands via crafted email inputs in the user synchronization script.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 May 2026
- **Updated:** 19 May 2026
- **Also known as:** GHSA-f59w-m967-9rf6

## What is CVE-2026-44194?

CVE-2026-44194 is a critical command injection vulnerability in opnsense core, published on 13 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.8, an authenticated Remote Code Execution (RCE) vulnerability in the OPNsense core allows a user with user-management privileges to execute arbitrary system commands as root. An attacker can bypass input validation by formatting their malicious payload as a compliant email address, allowing shell commands to reach the underlying operating system. The flaw exists in the local user synchronization flow, within core/src/opnsense/scripts/auth/sync_user.php. This vulnerability is fixed in 26.1.8.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-44194?

It affects 1 product.


Products: Opnsense Opnsense.

## How do I fix CVE-2026-44194?

No fix has been published for CVE-2026-44194 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44194 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44194 exists.

## Other vulnerabilities in opnsense core

- [CVE-2023-27152](https://insights.sbomify.com/CVE-2023-27152/): Auth bypass in n/a (critical 9.8)
- [CVE-2023-39001](https://insights.sbomify.com/CVE-2023-39001/): Command injection in n/a (critical 9.8)
- [CVE-2023-39004](https://insights.sbomify.com/CVE-2023-39004/): Information disclosure in n/a (critical 9.8)
- [CVE-2023-39008](https://insights.sbomify.com/CVE-2023-39008/): Command injection in n/a (critical 9.8)
- [CVE-2023-39007](https://insights.sbomify.com/CVE-2023-39007/): Cross-site scripting in n/a (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44194 and fix it if it is affected.

What it is: CVE-2026-44194 is a critical command injection vulnerability in opnsense core, published on 13 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44194 exists.

Affected product: opnsense core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44194/ (Markdown: https://insights.sbomify.com/CVE-2026-44194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44194
- OSV: https://osv.dev/vulnerability/CVE-2026-44194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44194/
Summaries are generated and may contain mistakes; the official description above is the record.
