# CVE-2026-44198: Wagtail: Improper permission handling when viewing page history

> Unauthorized CMS users can view page history reports, leading to potential disclosure of sensitive information.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-c4mr-889m-vgf6, PYSEC-2026-147, ROOT-APP-PYPI-CVE-2026-44198

## What is CVE-2026-44198?

CVE-2026-44198 is a medium-severity missing authorization vulnerability in wagtail, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Wagtail is an open source content management system built on Django. Prior to 7.0.7, 7.3.2, and 7.4, a CMS user without the ability to edit a page could still access the history report for the page, potentially resulting in disclosure of sensitive information. This vulnerability is fixed in 7.0.7, 7.3.2, and 7.4.

Weakness: CWE-280 (Improper Handling of Insufficient Permissions or Privileges)

## Which versions are affected by CVE-2026-44198?

5 open source packages ship an affected version, including wagtail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wagtail` | PyPI | All versions | 7.0.7, 7.3.2 |
| `wagtail` | PyPI | All versions | 7.0.7 |
| `wagtail` | PyPI | All versions | 7.0.7 |
| `wagtail` | PyPI | From 7.1 | 7.3.2 |
| `wagtail` | PyPI | From 7.1 | 7.3.2 |

Products: Torchbox Wagtail.

## How do I fix CVE-2026-44198?

Upgrade wagtail to a fixed version for your release line: 7.0.7 or 7.3.2.

## Is CVE-2026-44198 being exploited?

There is no known exploitation of CVE-2026-44198 in the wild and no public exploit code.

## Other vulnerabilities in wagtail

- [CVE-2026-54263](https://insights.sbomify.com/CVE-2026-54263/): Wagtail: Reflected XSS in dynamic image URL generator view (high 7.3)
- [CVE-2026-54261](https://insights.sbomify.com/CVE-2026-54261/): Wagtail: Improper permission handling in image preview (medium 6.5)
- [CVE-2026-44197](https://insights.sbomify.com/CVE-2026-44197/): Wagtail: Improper permission handling when comparing revisions (medium 6.5)
- [CVE-2026-44199](https://insights.sbomify.com/CVE-2026-44199/): Wagtail: Improper permission handling when deleting form submissions (medium 6.5)
- [CVE-2026-44200](https://insights.sbomify.com/CVE-2026-44200/): Wagtail: Improper permission handling when copying pages (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44198 and fix it if it is affected.

What it is: CVE-2026-44198 is a medium-severity missing authorization vulnerability in wagtail, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44198 in the wild and no public exploit code.

Affected packages and fixed versions:
- wagtail (PyPI): affected all versions; fixed in 7.0.7, 7.3.2
- wagtail (PyPI): affected all versions; fixed in 7.0.7
- wagtail (PyPI): affected all versions; fixed in 7.0.7
- wagtail (PyPI): affected from 7.1; fixed in 7.3.2
- wagtail (PyPI): affected from 7.1; fixed in 7.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44198/ (Markdown: https://insights.sbomify.com/CVE-2026-44198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44198
- OSV: https://osv.dev/vulnerability/CVE-2026-44198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44198/
Summaries are generated and may contain mistakes; the official description above is the record.
