{"answers":{"affected":"2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-core.","exploited":"There is no known exploitation of CVE-2026-44202 in the wild and no public exploit code.","fix":"Upgrade org.openidentityplatform.openam:openam-core to 16.1.1 or later.","what":"CVE-2026-44202 is a medium-severity server-side request forgery vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44202 and fix it if it is affected.\n\nWhat it is: CVE-2026-44202 is a medium-severity server-side request forgery vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44202 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.openidentityplatform.openam:openam-core (Maven): affected all versions; fixed in 16.1.1\n- org.openidentityplatform.openam:openam-core (Maven): affected all versions; fixed in 16.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44202/ (Markdown: https://insights.sbomify.com/CVE-2026-44202/index.md)","id":"CVE-2026-44202","markdown":"https://insights.sbomify.com/CVE-2026-44202/index.md","name":"CVE-2026-44202","record":{"aliases":["GHSA-c556-q2mh-477v","UBUNTU-CVE-2026-44202"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenAM access management","requires_auth":"low_privilege","summary":"Authenticated attackers can trigger server-side requests to arbitrary URLs via the session service, potentially disclosing sensitive session data.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, the /sessionservice addSessionListener operation allows an authenticated user to register an arbitrary notification URL without requiring an administrative or application client token. SessionRequestHandler passes the attacker-controlled destination to the session listener service, causing the OpenAM server to make outbound requests and potentially disclose session-related notification data to an attacker-controlled destination. This issue is fixed in version 16.1.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenAM Authenticated Server-Side Request Forgery (SSRF) via `/sessionservice`","id":"CVE-2026-44202","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"OpenAM: Pre-auth Reflected XSS in OAuth2 / OIDC response_mode=form_post via state parameter (FormPostResponse.ftl)","id":"CVE-2026-44203"},"packages":[{"ecosystem":"Maven","fixed":["16.1.1"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-core","purl":null,"source":"GHSA-c556-q2mh-477v"},{"ecosystem":"Maven","fixed":["16.1.1"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-core","purl":"pkg:maven/org.openidentityplatform.openam/openam-core","source":"GHSA-c556-q2mh-477v"}],"prev":{"headline":"Wagtail: Improper restriction handling on Documents and Images API","id":"CVE-2026-44201"},"products":["OpenAM"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-15","vendors":["OpenIdentityPlatform"]},"summary":"Authenticated attackers can trigger server-side requests to arbitrary URLs via the session service, potentially disclosing sensitive session data.","url":"https://insights.sbomify.com/CVE-2026-44202/"}