# CVE-2026-44202: OpenAM Authenticated Server-Side Request Forgery (SSRF) via `/sessionservice`

> Authenticated attackers can trigger server-side requests to arbitrary URLs via the session service, potentially disclosing sensitive session data.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-c556-q2mh-477v, UBUNTU-CVE-2026-44202

## What is CVE-2026-44202?

CVE-2026-44202 is a medium-severity server-side request forgery vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, the /sessionservice addSessionListener operation allows an authenticated user to register an arbitrary notification URL without requiring an administrative or application client token. SessionRequestHandler passes the attacker-controlled destination to the session listener service, causing the OpenAM server to make outbound requests and potentially disclose session-related notification data to an attacker-controlled destination. This issue is fixed in version 16.1.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-44202?

2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openidentityplatform.openam:openam-core` | Maven | All versions | 16.1.1 |
| `org.openidentityplatform.openam:openam-core` | Maven | All versions | 16.1.1 |

## How do I fix CVE-2026-44202?

Upgrade org.openidentityplatform.openam:openam-core to 16.1.1 or later.

## Is CVE-2026-44202 being exploited?

There is no known exploitation of CVE-2026-44202 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44202 and fix it if it is affected.

What it is: CVE-2026-44202 is a medium-severity server-side request forgery vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44202 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.openidentityplatform.openam:openam-core (Maven): affected all versions; fixed in 16.1.1
- org.openidentityplatform.openam:openam-core (Maven): affected all versions; fixed in 16.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44202/ (Markdown: https://insights.sbomify.com/CVE-2026-44202/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44202
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44202
- OSV: https://osv.dev/vulnerability/CVE-2026-44202

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44202/
Summaries are generated and may contain mistakes; the official description above is the record.
