{"answers":{"affected":"2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-oauth2.","exploited":"There is no known exploitation of CVE-2026-44203 in the wild and no public exploit code.","fix":"Upgrade org.openidentityplatform.openam:openam-oauth2 to 16.1.1 or later.","what":"CVE-2026-44203 is a high-severity cross-site scripting vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-44203 and fix it if it is affected.\n\nWhat it is: CVE-2026-44203 is a high-severity cross-site scripting vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-44203 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.openidentityplatform.openam:openam-oauth2 (Maven): affected from 13.0.0; fixed in 16.1.1\n- org.openidentityplatform.openam:openam-oauth2 (Maven): affected from 13.0.0; fixed in 16.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44203/ (Markdown: https://insights.sbomify.com/CVE-2026-44203/index.md)","id":"CVE-2026-44203","markdown":"https://insights.sbomify.com/CVE-2026-44203/index.md","name":"CVE-2026-44203","record":{"aliases":["GHSA-fq9h-c788-fx73","UBUNTU-CVE-2026-44203"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenAM access management","requires_auth":"none","summary":"An unauthenticated attacker can execute arbitrary script in the OpenAM origin via a crafted OAuth2 authorization request, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:H/VA:N/SC:L/SI:H/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, the OAuth 2.0 and OpenID Connect authorization endpoint does not sufficiently encode user-supplied parameters before FormPostResponse.ftl and checkSession.ftl render them into HTML for the form_post response mode. An unauthenticated attacker can induce a user to open a crafted authorization request and execute script in the OpenAM origin. This issue is fixed in version 16.1.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenAM: Pre-auth Reflected XSS in OAuth2 / OIDC response_mode=form_post via state parameter (FormPostResponse.ftl)","id":"CVE-2026-44203","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Shelf: SQL Injection via sortBy Parameter","id":"CVE-2026-44204"},"packages":[{"ecosystem":"Maven","fixed":["16.1.1"],"introduced":["13.0.0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-oauth2","purl":null,"source":"GHSA-fq9h-c788-fx73"},{"ecosystem":"Maven","fixed":["16.1.1"],"introduced":["13.0.0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-oauth2","purl":"pkg:maven/org.openidentityplatform.openam/openam-oauth2","source":"GHSA-fq9h-c788-fx73"}],"prev":{"headline":"OpenAM Authenticated Server-Side Request Forgery (SSRF) via `/sessionservice`","id":"CVE-2026-44202"},"products":["OpenAM"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["OpenIdentityPlatform"]},"summary":"An unauthenticated attacker can execute arbitrary script in the OpenAM origin via a crafted OAuth2 authorization request, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2026-44203/"}