# CVE-2026-44203: OpenAM: Pre-auth Reflected XSS in OAuth2 / OIDC response_mode=form_post via state parameter (FormPostResponse.ftl)

> An unauthenticated attacker can execute arbitrary script in the OpenAM origin via a crafted OAuth2 authorization request, potentially leading to account takeover.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:H/VA:N/SC:L/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-fq9h-c788-fx73, UBUNTU-CVE-2026-44203

## What is CVE-2026-44203?

CVE-2026-44203 is a high-severity cross-site scripting vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, the OAuth 2.0 and OpenID Connect authorization endpoint does not sufficiently encode user-supplied parameters before FormPostResponse.ftl and checkSession.ftl render them into HTML for the form_post response mode. An unauthenticated attacker can induce a user to open a crafted authorization request and execute script in the OpenAM origin. This issue is fixed in version 16.1.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-44203?

2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-oauth2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openidentityplatform.openam:openam-oauth2` | Maven | From 13.0.0 | 16.1.1 |
| `org.openidentityplatform.openam:openam-oauth2` | Maven | From 13.0.0 | 16.1.1 |

## How do I fix CVE-2026-44203?

Upgrade org.openidentityplatform.openam:openam-oauth2 to 16.1.1 or later.

## Is CVE-2026-44203 being exploited?

There is no known exploitation of CVE-2026-44203 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44203 and fix it if it is affected.

What it is: CVE-2026-44203 is a high-severity cross-site scripting vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-44203 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.openidentityplatform.openam:openam-oauth2 (Maven): affected from 13.0.0; fixed in 16.1.1
- org.openidentityplatform.openam:openam-oauth2 (Maven): affected from 13.0.0; fixed in 16.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44203/ (Markdown: https://insights.sbomify.com/CVE-2026-44203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44203
- OSV: https://osv.dev/vulnerability/CVE-2026-44203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44203/
Summaries are generated and may contain mistakes; the official description above is the record.
