{"answers":{"affected":"3 open source packages ship an affected version, including banks.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44209 exists.","fix":"Upgrade banks to 2.4.2 or later.","what":"CVE-2026-44209 is a high-severity code injection vulnerability in masci banks, published on 26 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-44209 and fix it if it is affected.\n\nWhat it is: CVE-2026-44209 is a high-severity code injection vulnerability in masci banks, published on 26 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44209 exists.\n\nAffected packages and fixed versions:\n- banks (PyPI): affected all versions; fixed in 2.4.2\n- banks (PyPI): affected all versions; fixed in 2.4.2\n- banks (PyPI): affected all versions; fixed in 2.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44209/ (Markdown: https://insights.sbomify.com/CVE-2026-44209/index.md)","id":"CVE-2026-44209","markdown":"https://insights.sbomify.com/CVE-2026-44209/index.md","name":"CVE-2026-44209","record":{"aliases":["GHSA-gphh-9q3h-jgpp","PYSEC-2026-2390"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python LLM prompt library","requires_auth":"none","summary":"Attackers can execute arbitrary code on the host system by injecting malicious templates into the Banks library if user input is passed directly to the prompt renderer.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-917","name":"Improper Neutralization of Special Elements used in an Expression Language Statement"},{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"Banks generates meaningful LLM prompts using a template language that makes sense. Prior to 2.4.2, banks uses jinja2.Environment() (unsandboxed) to render prompt templates. Applications that pass user-supplied strings as the template argument to Prompt() are vulnerable to Server-Side Template Injection (SSTI), which can lead to Remote Code Execution (RCE) on the host system. This vulnerability is fixed in 2.4.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Banks: Critical Remote Code Execution (RCE) via Jinja2 SSTI","id":"CVE-2026-44209","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Kata Containers have VM Escape via virtiofsd Argument Injection through Default-Enabled Pod Annotations","id":"CVE-2026-44210"},"packages":[{"ecosystem":"PyPI","fixed":["2.4.2"],"introduced":["0"],"last_affected":[],"package":"banks","purl":null,"source":"GHSA-gphh-9q3h-jgpp"},{"ecosystem":"PyPI","fixed":["2.4.2"],"introduced":["0"],"last_affected":[],"package":"banks","purl":"pkg:pypi/banks","source":"GHSA-gphh-9q3h-jgpp"},{"ecosystem":"PyPI","fixed":["2.4.2"],"introduced":["0"],"last_affected":[],"package":"banks","purl":"pkg:pypi/banks","source":"PYSEC-2026-2390"}],"prev":{"headline":"Frappe: IDOR in `submit_discussion()`","id":"CVE-2026-44208"},"products":["banks"],"published":"2026-05-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-24","vendors":["masci"]},"summary":"Attackers can execute arbitrary code on the host system by injecting malicious templates into the Banks library if user input is passed directly to the prompt renderer.","url":"https://insights.sbomify.com/CVE-2026-44209/"}