# CVE-2026-44209: Banks: Critical Remote Code Execution (RCE) via Jinja2 SSTI

> Attackers can execute arbitrary code on the host system by injecting malicious templates into the Banks library if user input is passed directly to the prompt renderer.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 May 2026
- **Updated:** 24 Jul 2026
- **Also known as:** GHSA-gphh-9q3h-jgpp, PYSEC-2026-2390

## What is CVE-2026-44209?

CVE-2026-44209 is a high-severity code injection vulnerability in masci banks, published on 26 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Banks generates meaningful LLM prompts using a template language that makes sense. Prior to 2.4.2, banks uses jinja2.Environment() (unsandboxed) to render prompt templates. Applications that pass user-supplied strings as the template argument to Prompt() are vulnerable to Server-Side Template Injection (SSTI), which can lead to Remote Code Execution (RCE) on the host system. This vulnerability is fixed in 2.4.2.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-44209?

3 open source packages ship an affected version, including banks.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `banks` | PyPI | All versions | 2.4.2 |
| `banks` | PyPI | All versions | 2.4.2 |
| `banks` | PyPI | All versions | 2.4.2 |

## How do I fix CVE-2026-44209?

Upgrade banks to 2.4.2 or later.

## Is CVE-2026-44209 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44209 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44209 and fix it if it is affected.

What it is: CVE-2026-44209 is a high-severity code injection vulnerability in masci banks, published on 26 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44209 exists.

Affected packages and fixed versions:
- banks (PyPI): affected all versions; fixed in 2.4.2
- banks (PyPI): affected all versions; fixed in 2.4.2
- banks (PyPI): affected all versions; fixed in 2.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44209/ (Markdown: https://insights.sbomify.com/CVE-2026-44209/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44209
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44209
- OSV: https://osv.dev/vulnerability/CVE-2026-44209

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44209/
Summaries are generated and may contain mistakes; the official description above is the record.
