# CVE-2026-44210: Kata Containers have VM Escape via virtiofsd Argument Injection through Default-Enabled Pod Annotations

> Attackers can escape VMs and access host files by injecting arguments into virtiofsd via default-enabled pod annotations in Kata Containers.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jul 2026
- **Updated:** 24 Jul 2026
- **Also known as:** AZL-93063, AZL-93066, GHSA-rr59-xxvx-96qr, GO-2026-5638

## What is CVE-2026-44210?

CVE-2026-44210 is a medium-severity command injection vulnerability in kata-containers, published on 23 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kata Containers is an open source project focusing on a standard implementation of lightweight Virtual Machines (VMs) that perform like containers. Versions prior to 3.31.0 ship with a default configuration that allows pod creators to inject arbitrary command-line arguments into the virtiofsd process through the `io.katacontainers.config.hypervisor.virtio_fs_extra_args` pod annotation. By injecting `-o source=/` along with `--no-announce-submounts` and `--sandbox=none`, an attacker can override the virtiofsd shared directory to serve the entire host root filesystem into the guest VM. Combined with the `kernel_params` annotation (also enabled by default) to activate the agent debug console, the attacker can mount the host filesystem from inside the VM and read or write any file on the host, including /etc/shadow. Version 3.31.0 patches the issue.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-44210?

3 open source packages ship an affected version, including github.com/kata-containers/kata-containers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kata-containers/kata-containers` | Go | All versions | 0.0.0-20260519062212-ffa59ce3aa78 |
| `github.com/kata-containers/kata-containers` | Go | All versions | 0.0.0-20260519062212-ffa59ce3aa78 |
| `github.com/kata-containers/kata-containers` | Go | All versions | 0.0.0-20260519062212-ffa59ce3aa78 |

Products: Katacontainers Kata Containers.

## How do I fix CVE-2026-44210?

Upgrade github.com/kata-containers/kata-containers to 0.0.0-20260519062212-ffa59ce3aa78 or later.

## Is CVE-2026-44210 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44210 exists.

## Other vulnerabilities in kata-containers

- [CVE-2026-24834](https://insights.sbomify.com/CVE-2026-24834/): Kata Container to Guest micro VM privilege escalation (critical 9.4)
- [CVE-2026-24054](https://insights.sbomify.com/CVE-2026-24054/): Other in kata-containers (high 8.8)
- [CVE-2020-27151](https://insights.sbomify.com/CVE-2020-27151/): Code injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44210 and fix it if it is affected.

What it is: CVE-2026-44210 is a medium-severity command injection vulnerability in kata-containers, published on 23 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44210 exists.

Affected packages and fixed versions:
- github.com/kata-containers/kata-containers (Go): affected all versions; fixed in 0.0.0-20260519062212-ffa59ce3aa78
- github.com/kata-containers/kata-containers (Go): affected all versions; fixed in 0.0.0-20260519062212-ffa59ce3aa78
- github.com/kata-containers/kata-containers (Go): affected all versions; fixed in 0.0.0-20260519062212-ffa59ce3aa78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44210/ (Markdown: https://insights.sbomify.com/CVE-2026-44210/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44210
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44210
- OSV: https://osv.dev/vulnerability/CVE-2026-44210

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44210/
Summaries are generated and may contain mistakes; the official description above is the record.
