{"answers":{"affected":"4 open source packages ship an affected version, including prestashop/prestashop.","exploited":"There is no known exploitation of CVE-2026-44212 in the wild and no public exploit code.","fix":"Upgrade prestashop/prestashop to a fixed version for your release line: 8.2.6 or 9.1.1.","what":"CVE-2026-44212 is a critical cross-site scripting vulnerability in PrestaShop, published on 14 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-44212 and fix it if it is affected.\n\nWhat it is: CVE-2026-44212 is a critical cross-site scripting vulnerability in PrestaShop, published on 14 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-44212 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prestashop/prestashop (Packagist): affected all versions; fixed in 8.2.6\n- prestashop/prestashop (Packagist): affected all versions; fixed in 8.2.6\n- prestashop/prestashop (Packagist): affected from 9.0.0; fixed in 9.1.1\n- prestashop/prestashop (Packagist): affected from 9.0.0; fixed in 9.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44212/ (Markdown: https://insights.sbomify.com/CVE-2026-44212/index.md)","id":"CVE-2026-44212","markdown":"https://insights.sbomify.com/CVE-2026-44212/index.md","name":"CVE-2026-44212","record":{"aliases":["GHSA-w9f3-qc75-qgx9"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"E-commerce platform","requires_auth":"none","summary":"An unauthenticated attacker can inject malicious scripts via the Contact Us form, leading to back-office session hijacking and full administrative takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"PrestaShop is an open source e-commerce web application. Prior to 8.2.6 and 9.1.1, there is a stored Cross-Site Scripting (XSS) vulnerability in the PrestaShop back-office Customer Service view. An unauthenticated attacker can submit the public Contact Us form with a malicious email address. The payload is stored in the database and executed when a back-office employee opens the affected customer thread, enabling session hijacking and full back-office takeover. This vulnerability is fixed in 8.2.6 and 9.1.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PrestaShop: Stored XSS executable in customer service view","id":"CVE-2026-44212","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"OpenTelemetry.Exporter.Instana bypasses TLS certificate validation when a proxy is configured","id":"CVE-2026-44213"},"packages":[{"ecosystem":"Packagist","fixed":["8.2.6"],"introduced":["0"],"last_affected":[],"package":"prestashop/prestashop","purl":null,"source":"GHSA-w9f3-qc75-qgx9"},{"ecosystem":"Packagist","fixed":["8.2.6"],"introduced":["0"],"last_affected":[],"package":"prestashop/prestashop","purl":"pkg:composer/prestashop/prestashop","source":"GHSA-w9f3-qc75-qgx9"},{"ecosystem":"Packagist","fixed":["9.1.1"],"introduced":["9.0.0"],"last_affected":[],"package":"prestashop/prestashop","purl":null,"source":"GHSA-w9f3-qc75-qgx9"},{"ecosystem":"Packagist","fixed":["9.1.1"],"introduced":["9.0.0"],"last_affected":[],"package":"prestashop/prestashop","purl":"pkg:composer/prestashop/prestashop","source":"GHSA-w9f3-qc75-qgx9"}],"prev":{"headline":"Cline Kanban Server has a Cross-Origin WebSocket Hijacking Vulnerability","id":"CVE-2026-44211"},"products":["PrestaShop"],"published":"2026-05-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-15","vendors":["PrestaShop"]},"summary":"An unauthenticated attacker can inject malicious scripts via the Contact Us form, leading to back-office session hijacking and full administrative takeover.","url":"https://insights.sbomify.com/CVE-2026-44212/"}