# CVE-2026-44212: PrestaShop: Stored XSS executable in customer service view

> An unauthenticated attacker can inject malicious scripts via the Contact Us form, leading to back-office session hijacking and full administrative takeover.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 15 May 2026
- **Also known as:** GHSA-w9f3-qc75-qgx9

## What is CVE-2026-44212?

CVE-2026-44212 is a critical cross-site scripting vulnerability in PrestaShop, published on 14 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PrestaShop is an open source e-commerce web application. Prior to 8.2.6 and 9.1.1, there is a stored Cross-Site Scripting (XSS) vulnerability in the PrestaShop back-office Customer Service view. An unauthenticated attacker can submit the public Contact Us form with a malicious email address. The payload is stored in the database and executed when a back-office employee opens the affected customer thread, enabling session hijacking and full back-office takeover. This vulnerability is fixed in 8.2.6 and 9.1.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-44212?

4 open source packages ship an affected version, including prestashop/prestashop.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | All versions | 8.2.6 |
| `prestashop/prestashop` | Packagist | All versions | 8.2.6 |
| `prestashop/prestashop` | Packagist | From 9.0.0 | 9.1.1 |
| `prestashop/prestashop` | Packagist | From 9.0.0 | 9.1.1 |

## How do I fix CVE-2026-44212?

Upgrade prestashop/prestashop to a fixed version for your release line: 8.2.6 or 9.1.1.

## Is CVE-2026-44212 being exploited?

There is no known exploitation of CVE-2026-44212 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44212 and fix it if it is affected.

What it is: CVE-2026-44212 is a critical cross-site scripting vulnerability in PrestaShop, published on 14 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-44212 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected all versions; fixed in 8.2.6
- prestashop/prestashop (Packagist): affected all versions; fixed in 8.2.6
- prestashop/prestashop (Packagist): affected from 9.0.0; fixed in 9.1.1
- prestashop/prestashop (Packagist): affected from 9.0.0; fixed in 9.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44212/ (Markdown: https://insights.sbomify.com/CVE-2026-44212/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44212
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44212
- OSV: https://osv.dev/vulnerability/CVE-2026-44212

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44212/
Summaries are generated and may contain mistakes; the official description above is the record.
