{"answers":{"affected":"2 open source packages ship an affected version, including eventsource-encoder. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44214 exists.","fix":"Upgrade eventsource-encoder to 1.0.2 or later.","what":"CVE-2026-44214 is a medium-severity vulnerability in rexxars eventsource-encoder, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44214 and fix it if it is affected.\n\nWhat it is: CVE-2026-44214 is a medium-severity vulnerability in rexxars eventsource-encoder, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44214 exists.\n\nAffected packages and fixed versions:\n- eventsource-encoder (npm): affected all versions; fixed in 1.0.2\n- eventsource-encoder (npm): affected all versions; fixed in 1.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44214/ (Markdown: https://insights.sbomify.com/CVE-2026-44214/index.md)","id":"CVE-2026-44214","markdown":"https://insights.sbomify.com/CVE-2026-44214/index.md","name":"CVE-2026-44214","record":{"aliases":["GHSA-m9g3-3g99-mhpx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"SSE encoding library","requires_auth":"none","summary":"Attackers can inject arbitrary SSE fields or messages by controlling unsanitized event or id fields in the eventsource-encoder library.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"eventsource-encoder","vendor":"rexxars"}],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-93","name":"Improper Neutralization of CRLF Sequences"},{"id":"CWE-113","name":"Improper Neutralization of CRLF Sequences in HTTP Headers"}],"description":"eventsource-encoder encodes events as well-formed EventSource/Server Sent Event (SSE) messages. Prior to 1.0.2, eventsource-encoder does not sanitize the event or id fields of an EventSourceMessage before serializing them. An attacker who controls either field can inject arbitrary Server-Sent Events line terminators (\\n, \\r, or \\r\\n) and thereby forge additional SSE fields or entire messages on the stream. This vulnerability is fixed in 1.0.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"eventsource-encoder: SSE event injection via unsanitized event and id fields","id":"CVE-2026-44214","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"NanaZip: Heap out-of-bounds write in NanaZip UFS directory parser","id":"CVE-2026-44215"},"packages":[{"ecosystem":"npm","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"eventsource-encoder","purl":null,"source":"GHSA-m9g3-3g99-mhpx"},{"ecosystem":"npm","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"eventsource-encoder","purl":"pkg:npm/eventsource-encoder","source":"GHSA-m9g3-3g99-mhpx"}],"prev":{"headline":"OpenTelemetry.Exporter.Instana bypasses TLS certificate validation when a proxy is configured","id":"CVE-2026-44213"},"products":["eventsource-encoder"],"published":"2026-05-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-27","vendors":["rexxars"]},"summary":"Attackers can inject arbitrary SSE fields or messages by controlling unsanitized event or id fields in the eventsource-encoder library.","url":"https://insights.sbomify.com/CVE-2026-44214/"}