# CVE-2026-44214: eventsource-encoder: SSE event injection via unsanitized event and id fields

> Attackers can inject arbitrary SSE fields or messages by controlling unsanitized event or id fields in the eventsource-encoder library.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-m9g3-3g99-mhpx

## What is CVE-2026-44214?

CVE-2026-44214 is a medium-severity vulnerability in rexxars eventsource-encoder, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

eventsource-encoder encodes events as well-formed EventSource/Server Sent Event (SSE) messages. Prior to 1.0.2, eventsource-encoder does not sanitize the event or id fields of an EventSourceMessage before serializing them. An attacker who controls either field can inject arbitrary Server-Sent Events line terminators (\n, \r, or \r\n) and thereby forge additional SSE fields or entire messages on the stream. This vulnerability is fixed in 1.0.2.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences), CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2026-44214?

2 open source packages ship an affected version, including eventsource-encoder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `eventsource-encoder` | npm | All versions | 1.0.2 |
| `eventsource-encoder` | npm | All versions | 1.0.2 |

Products: Rexxars Eventsource-Encoder.

## How do I fix CVE-2026-44214?

Upgrade eventsource-encoder to 1.0.2 or later.

## Is CVE-2026-44214 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44214 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44214 and fix it if it is affected.

What it is: CVE-2026-44214 is a medium-severity vulnerability in rexxars eventsource-encoder, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44214 exists.

Affected packages and fixed versions:
- eventsource-encoder (npm): affected all versions; fixed in 1.0.2
- eventsource-encoder (npm): affected all versions; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44214/ (Markdown: https://insights.sbomify.com/CVE-2026-44214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44214
- OSV: https://osv.dev/vulnerability/CVE-2026-44214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44214/
Summaries are generated and may contain mistakes; the official description above is the record.
