# CVE-2026-44217: sse-channel: SSE Injection via unsanitized event fields

> Attackers can inject arbitrary messages into Server-Sent Events streams by exploiting unsanitized event fields in the sse-channel library.

- **Severity:** Medium 6.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-84hm-wfh8-c5pg

## What is CVE-2026-44217?

CVE-2026-44217 is a medium-severity vulnerability in rexxars sse-channel, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

sse-channel is an SSE-implementation which can be used to any node.js http request/response stream. Prior to 4.0.1, implementations that allow user-provided values to be passed to event, retry or id fields are susceptible to event spoofing, where an attacker could inject arbitrary messages into the stream. This vulnerability is fixed in 4.0.1.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-44217?

2 open source packages ship an affected version, including sse-channel.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sse-channel` | npm | All versions | 4.0.1 |
| `sse-channel` | npm | All versions | 4.0.1 |

## How do I fix CVE-2026-44217?

Upgrade sse-channel to 4.0.1 or later.

## Is CVE-2026-44217 being exploited?

There is no known exploitation of CVE-2026-44217 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44217 and fix it if it is affected.

What it is: CVE-2026-44217 is a medium-severity vulnerability in rexxars sse-channel, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44217 in the wild and no public exploit code.

Affected packages and fixed versions:
- sse-channel (npm): affected all versions; fixed in 4.0.1
- sse-channel (npm): affected all versions; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44217/ (Markdown: https://insights.sbomify.com/CVE-2026-44217/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44217
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44217
- OSV: https://osv.dev/vulnerability/CVE-2026-44217

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44217/
Summaries are generated and may contain mistakes; the official description above is the record.
