# CVE-2026-44220: ciguard: discover_pipeline_files follows symlinks out of scan root

> An attacker can plant symlinks to force the CI/CD auditor to read pipeline files outside the intended scan directory.

- **Severity:** Low 3.2 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 13 May 2026
- **Also known as:** GHSA-8cxw-cc62-q28v, PYSEC-2026-2408

## What is CVE-2026-44220?

CVE-2026-44220 is a low-severity path traversal vulnerability in Jo-Jo98 ciguard, published on 12 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

ciguard is a static security auditor for CI/CD pipelines. From 0.8.0 to 0.8.1 , the discover_pipeline_files() function in src/ciguard/discovery.py walks a directory tree following symlinks, with cycle protection via tracking visited resolved paths. An attacker who can plant a symlink in a directory the user (or AI agent) scans can cause discovery to walk into the symlink target and return paths to pipeline-shaped files outside the requested root. This vulnerability is fixed in 0.8.2.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2026-44220?

3 open source packages ship an affected version, including ciguard.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ciguard` | PyPI | From 0.8.0 | 0.8.2 |
| `ciguard` | PyPI | From 0.8.0 | 0.8.2 |
| `ciguard` | PyPI | From 0.8.0 | 0.8.2 |

## How do I fix CVE-2026-44220?

Upgrade ciguard to 0.8.2 or later.

## Is CVE-2026-44220 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44220 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44220 and fix it if it is affected.

What it is: CVE-2026-44220 is a low-severity path traversal vulnerability in Jo-Jo98 ciguard, published on 12 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44220 exists.

Affected packages and fixed versions:
- ciguard (PyPI): affected from 0.8.0; fixed in 0.8.2
- ciguard (PyPI): affected from 0.8.0; fixed in 0.8.2
- ciguard (PyPI): affected from 0.8.0; fixed in 0.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44220/ (Markdown: https://insights.sbomify.com/CVE-2026-44220/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44220
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44220
- OSV: https://osv.dev/vulnerability/CVE-2026-44220

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44220/
Summaries are generated and may contain mistakes; the official description above is the record.
