CVE-2026-44223 vLLM: extract_hidden_states speculative decoding crashes server on any request with penalty parameters
Attackers can crash the vLLM server by sending requests with penalty parameters when speculative decoding is enabled, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44223?
CVE-2026-44223 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
vLLM is an inference and serving engine for large language models (LLMs). From 0.18.0 to before 0.20.0, the extract_hidden_states speculative decoding proposer in vLLM returns a tensor with an incorrect shape after the first decode step, causing a RuntimeError that crashes the EngineCore process. The crash is triggered when any request in the batch uses sampling penalty parameters (repetition_penalty, frequency_penalty, or presence_penalty). A single request with a penalty parameter (e.g., "repetition_penalty": 1.1) is sufficient to crash the server. This vulnerability is fixed in 0.20.0.
Which versions are affected by CVE-2026-44223?
3 open source packages ship an affected version, including vllm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
vllm PyPI | From 0.18.0 | 0.20.0 |
vllm PyPI | From 0.18.0 | 0.20.0 |
vllm PyPI | From 0.18.0 | 0.20.0 |
Products include Vllm Vllm.
How do I fix CVE-2026-44223?
Upgrade vllm to 0.20.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-44223 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44223 exists.
Other vulnerabilities in Vllm Vllm
- CVE-2025-32444 vLLM Vulnerable to Remote Code Execution via Mooncake Integration
- CVE-2026-22778 vLLM leaks a heap address when PIL throws an error
- CVE-2025-47277 vLLM Allows Remote Code Execution via PyNcclPipe Communication Service
- CVE-2024-11041 Remote Code Execution in vllm-project/vllm
- CVE-2026-48746 vLLM: OpenAI auth bypass
Sources
Also known as GHSA-83vm-p52w-f9pw, MINI-w4gc-rp6c-cm85, PYSEC-2026-145.