{"answers":{"affected":"3 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44223 exists.","fix":"Upgrade vllm to 0.20.0 or later.","what":"CVE-2026-44223 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44223 and fix it if it is affected.\n\nWhat it is: CVE-2026-44223 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44223 exists.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.18.0; fixed in 0.20.0\n- vllm (PyPI): affected from 0.18.0; fixed in 0.20.0\n- vllm (PyPI): affected from 0.18.0; fixed in 0.20.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44223/ (Markdown: https://insights.sbomify.com/CVE-2026-44223/index.md)","id":"CVE-2026-44223","markdown":"https://insights.sbomify.com/CVE-2026-44223/index.md","name":"CVE-2026-44223","record":{"aliases":["GHSA-83vm-p52w-f9pw","MINI-w4gc-rp6c-cm85","PYSEC-2026-145"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"LLM inference engine","requires_auth":"low_privilege","summary":"Attackers can crash the vLLM server by sending requests with penalty parameters when speculative decoding is enabled, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-704","name":"Incorrect Type Conversion or Cast"},{"id":"CWE-131","name":"Incorrect Calculation of Buffer Size"}],"description":"vLLM is an inference and serving engine for large language models (LLMs). From 0.18.0 to before 0.20.0, the extract_hidden_states speculative decoding proposer in vLLM returns a tensor with an incorrect shape after the first decode step, causing a RuntimeError that crashes the EngineCore process. The crash is triggered when any request in the batch uses sampling penalty parameters (repetition_penalty, frequency_penalty, or presence_penalty). A single request with a penalty parameter (e.g., \"repetition_penalty\": 1.1) is sufficient to crash the server. This vulnerability is fixed in 0.20.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vLLM: extract_hidden_states speculative decoding crashes server on any request with penalty parameters","id":"CVE-2026-44223","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Wiki.js: Privilege Escalation via Missing Group Validation in users.update","id":"CVE-2026-44224"},"packages":[{"ecosystem":"PyPI","fixed":["0.20.0"],"introduced":["0.18.0"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-83vm-p52w-f9pw"},{"ecosystem":"PyPI","fixed":["0.20.0"],"introduced":["0.18.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-83vm-p52w-f9pw"},{"ecosystem":"PyPI","fixed":["0.20.0"],"introduced":["0.18.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2026-145"}],"prev":{"headline":"vLLM: Remote DoS via Special-Token Placeholders","id":"CVE-2026-44222"},"products":["vllm"],"published":"2026-05-12","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-22","vendors":["vllm-project"]},"summary":"Attackers can crash the vLLM server by sending requests with penalty parameters when speculative decoding is enabled, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2026-44223/"}