# CVE-2026-44223: vLLM: extract_hidden_states speculative decoding crashes server on any request with penalty parameters

> Attackers can crash the vLLM server by sending requests with penalty parameters when speculative decoding is enabled, causing a denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-83vm-p52w-f9pw, MINI-w4gc-rp6c-cm85, PYSEC-2026-145

## What is CVE-2026-44223?

CVE-2026-44223 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). From 0.18.0 to before 0.20.0, the extract_hidden_states speculative decoding proposer in vLLM returns a tensor with an incorrect shape after the first decode step, causing a RuntimeError that crashes the EngineCore process. The crash is triggered when any request in the batch uses sampling penalty parameters (repetition_penalty, frequency_penalty, or presence_penalty). A single request with a penalty parameter (e.g., "repetition_penalty": 1.1) is sufficient to crash the server. This vulnerability is fixed in 0.20.0.

Weakness: CWE-704 (Incorrect Type Conversion or Cast), CWE-131 (Incorrect Calculation of Buffer Size)

## Which versions are affected by CVE-2026-44223?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.18.0 | 0.20.0 |
| `vllm` | PyPI | From 0.18.0 | 0.20.0 |
| `vllm` | PyPI | From 0.18.0 | 0.20.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-44223?

Upgrade vllm to 0.20.0 or later.

## Is CVE-2026-44223 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44223 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44223 and fix it if it is affected.

What it is: CVE-2026-44223 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44223 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.18.0; fixed in 0.20.0
- vllm (PyPI): affected from 0.18.0; fixed in 0.20.0
- vllm (PyPI): affected from 0.18.0; fixed in 0.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44223/ (Markdown: https://insights.sbomify.com/CVE-2026-44223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44223
- OSV: https://osv.dev/vulnerability/CVE-2026-44223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44223/
Summaries are generated and may contain mistakes; the official description above is the record.
