{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44225 exists.","fix":"No fix has been published for CVE-2026-44225 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-44225 is a critical path traversal vulnerability in enesgkky Pulpy, published on 12 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-44225 and fix it if it is affected.\n\nWhat it is: CVE-2026-44225 is a critical path traversal vulnerability in enesgkky Pulpy, published on 12 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44225 exists.\n\nAffected product: enesgkky Pulpy. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44225/ (Markdown: https://insights.sbomify.com/CVE-2026-44225/index.md)","id":"CVE-2026-44225","markdown":"https://insights.sbomify.com/CVE-2026-44225/index.md","name":"CVE-2026-44225","record":{"aliases":[],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Desktop app packager","requires_auth":"none","summary":"Packaged web apps can bypass filesystem sandboxing to read and write arbitrary user files, including sensitive credentials.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Pulpy is a lightweight, cross-platform desktop application packager for web apps. Prior to 0.1.1, Pulpy injects a pulpy.fs JavaScript API into every packaged web application, giving it access to the host filesystem. A validateFsPath() function is supposed to sandbox this access, but its blocklist is incomplete. Any web app packaged with Pulpy can read and write arbitrary files in the user's home directory — including ~/.ssh/id_rsa, ~/.aws/credentials, and ~/Library/Keychains/. This vulnerability is fixed in 0.1.1.","ecosystems":[],"exploits":{"exploitdb":1,"first_seen":"2026-07-06","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-07-06","kind":"exploitdb","ref":"52616","stars":null,"title":"Pulpy 0.1.1-Beta - Filesystem Sandbox Bypass"}],"tier":"weaponised"},"has_fix":null,"headline":"Pulpy: Incomplete filesystem sandbox in pulpy.fs bridge allows packaged web apps to read arbitrary user files","id":"CVE-2026-44225","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"pyLoad: Unauthenticated traceback disclosure via global exception handler in WebUI","id":"CVE-2026-44226"},"packages":[],"prev":{"headline":"Wiki.js: Privilege Escalation via Missing Group Validation in users.update","id":"CVE-2026-44224"},"products":["Pulpy"],"published":"2026-05-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-14","vendors":["enesgkky"]},"summary":"Packaged web apps can bypass filesystem sandboxing to read and write arbitrary user files, including sensitive credentials.","url":"https://insights.sbomify.com/CVE-2026-44225/"}