# CVE-2026-44225: Pulpy: Incomplete filesystem sandbox in pulpy.fs bridge allows packaged web apps to read arbitrary user files

> Packaged web apps can bypass filesystem sandboxing to read and write arbitrary user files, including sensitive credentials.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 12 May 2026
- **Updated:** 14 May 2026

## What is CVE-2026-44225?

CVE-2026-44225 is a critical path traversal vulnerability in enesgkky Pulpy, published on 12 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Pulpy is a lightweight, cross-platform desktop application packager for web apps. Prior to 0.1.1, Pulpy injects a pulpy.fs JavaScript API into every packaged web application, giving it access to the host filesystem. A validateFsPath() function is supposed to sandbox this access, but its blocklist is incomplete. Any web app packaged with Pulpy can read and write arbitrary files in the user's home directory — including ~/.ssh/id_rsa, ~/.aws/credentials, and ~/Library/Keychains/. This vulnerability is fixed in 0.1.1.

Weakness: CWE-284 (Improper Access Control), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-44225?


## How do I fix CVE-2026-44225?

No fix has been published for CVE-2026-44225 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44225 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44225 exists.

Public exploit code:

- Pulpy 0.1.1-Beta - Filesystem Sandbox Bypass (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44225 and fix it if it is affected.

What it is: CVE-2026-44225 is a critical path traversal vulnerability in enesgkky Pulpy, published on 12 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44225 exists.

Affected product: enesgkky Pulpy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44225/ (Markdown: https://insights.sbomify.com/CVE-2026-44225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44225
- OSV: https://osv.dev/vulnerability/CVE-2026-44225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44225/
Summaries are generated and may contain mistakes; the official description above is the record.
